Opened 12 years ago

Closed 12 years ago

#3023 closed Bug (duplicate)

Incorrect display of ratio

Reported by: Robby Owned by: charles
Priority: Normal Milestone: None Set
Component: libtransmission Version: 1.91
Severity: Normal Keywords:
Cc:

Description

Transmission appears to display an incorrect ratio. I have seen this several times. In this case it occurs with both T Mac and the Web Client, I'm not sure this has always been like that.

As charles suggested when I originally ran into the issue I extracted the byte counts from the file "Transmission/resume/your-torrent-name-SHA1-UNIQUENESS-HASH.resume":

  • downloadedi693753135e9
  • uploadedi744193052ee

Screenshot of Mac Transmission and Web Client attached.

I'm very willing to supply any additional information needed. :)

Attachments (1)

Bild 2 censored.png (106.2 KB) - added by Robby 12 years ago.
Screenshot T Mac and Web Client side-by-side

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by Robby

Screenshot T Mac and Web Client side-by-side

comment:1 Changed 12 years ago by Robby

Result when dividing the "uploaded" byte count by the "downloaded" byte count: 1,072705858114789, dividing the uploaded value shown in the main window by the downloaded value: 1,117637795275591. Is this some logical mistake on my part?

comment:2 Changed 12 years ago by charles

  • Component changed from Transmission to Mac Client
  • Owner set to livings124

comment:3 Changed 12 years ago by livings124

  • Component changed from Mac Client to libtransmission
  • Owner changed from livings124 to charles

The value displayed in the main window's status bar is from tr_sessionGetCumulativeStats()'s or tr_sessionGetStats()'s returned tr_session_stats.ratio. The value displayed for each torrent is tr_stat's ratio value.

comment:4 Changed 12 years ago by charles

I think livings124 is right here. It looks to me like both the mac and web client are showing the 1.07 ratio for the torrent, but the cumulative ratio is slightly higher.

Or, Robby, are you saying this is the only torrent you've ever used since the last time you erased all the config files and started from scratch?

comment:5 Changed 12 years ago by Robby

I'm sorry for the confusion but I never meant to reference the cumulative ratio.

Replying to Robby:

[...]dividing the uploaded value shown in the main window by the downloaded value: 1,117637795275591.[...]

I meant the values for the torrent: 709,7 MB uploaded, 635 MB downloaded.

comment:6 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

But you haven't downloaded 635 MB, you've downloaded 661.61 MB. I think you're getting tripped up by the `overdownloading' bug http://trac.transmissionbt.com/ticket/2993

Marking this as a duplicate of #2993.

Thanks for the report :)

Note: See TracTickets for help on using tickets.