Opened 12 years ago

Closed 12 years ago

#3028 closed Bug (invalid)

Daemon won't run with empty settings.json

Reported by: ferrous26 Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.91
Severity: Normal Keywords:
Cc:

Description

If my settings.json file exists, but is completely empty, then the transmission daemon refuses to run citing that it had a problem loading the settings.json file at daemon.c:400.

If I put an empty object in the settings.json file then everything works fine, if I have no settings.json file then everything works fine, but an empty settings.json doesn't work.

I'm not sure how my settings.json file became empty (I didn't do it), but it took me a good while figure out why my transmission daemon would not start up.

Change History (1)

comment:1 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

This is a feature, not a bug.

What was happening was that some users had corrupt settings.json files, which could only be partially parsed, and Transmission resorted to default values for the missing keys. This caused more harm than good because users didn't understand why their files' settings weren't being honored.

Note: See TracTickets for help on using tickets.