Opened 11 years ago

Closed 11 years ago

#3041 closed Bug (fixed)

Blocklist - bad peers decreases after update; corrupt error messages

Reported by: Ryoujin Owned by: livings124
Priority: Normal Milestone: 1.93
Component: Transmission Version: 1.91
Severity: Normal Keywords:
Cc:

Description

(Originally posted in the forums) I've been experiencing this issue for a while (a couple of weeks ago). Right now I'm using r10352, and sometimes when I update the blocklist the total known bad peers number drops from 224,282 to 198,181 (-26,101).

Afterwards, I tried copying the bunch of random IPs that showed up in the Error log, but as soon as I tried to copy it Transmission crashed.

Attachments (13)

Transmission_2010-03-10-192944_Black.crash (34.2 KB) - added by Ryoujin 11 years ago.
Crash log
Console Messages.log (63.4 KB) - added by Ryoujin 11 years ago.
Console Messages
Console Messages part 01.log (13.9 KB) - added by Ryoujin 11 years ago.
Console Messages part 1
Console Messages part 02.log (16.0 KB) - added by Ryoujin 11 years ago.
Console Messages part 2
Console Messages.2.log (16.2 KB) - added by Ryoujin 11 years ago.
Console Messages.3.log (3.3 KB) - added by Ryoujin 11 years ago.
Console Messages.4.log (6.5 KB) - added by Ryoujin 11 years ago.
patch.diff (785 bytes) - added by livings124 11 years ago.
Console Messages.5.log (4.5 KB) - added by Ryoujin 11 years ago.
Console Messages.6.log (17.3 KB) - added by Ryoujin 11 years ago.
Console Messages.7.log (14.4 KB) - added by Ryoujin 11 years ago.
Console Messages.8.log (58.5 KB) - added by Ryoujin 11 years ago.
Console Messages.9.log (16.7 KB) - added by Ryoujin 11 years ago.

Download all attachments as: .zip

Change History (73)

Changed 11 years ago by Ryoujin

Crash log

comment:1 Changed 11 years ago by livings124

  • Component changed from Transmission to Mac Client
  • Owner set to livings124

That's a strange one. Can you generate a crash log from a nightly from http://transmission.xpjets.com/ (assuming you aren't).

comment:2 Changed 11 years ago by Ryoujin

Since September 29, 2009 I've been getting the nightlies from build.transmissionbt, since it seemed that transmission.xpjets wasn't getting updated. I just replaced the version I had from the first website (r10367) with the one from the second (r10367). I'll switch sites from now on.

I tried to reproduce the crash, but since the decrease thing happens randomly I'll probably have to report back when I pops up again.

comment:3 Changed 11 years ago by Ryoujin

I could reproduce the bug, but some weird things happened:

  • First I tried to copy the contents, but the whole Message Log dialog locked up. I'm attaching what the Console said (I guess it has some sort of relation).
  • Then I closed the window and tried again, I could select and try copying, but pasting would end up in nothing. I also tried the Save... option, no file came up. My guess is that it was too long for it to copy (because I could select one by one and it would come thru).

So I took a couple of screenshots of the contents of the Message Log.

http://i43.tinypic.com/f8403.jpg http://i43.tinypic.com/2rw1fzc.png

Compared to the first report, this time it didn't crash, tho.

Changed 11 years ago by Ryoujin

Console Messages

comment:4 Changed 11 years ago by livings124

Is there a crash log to go with this? Have you set any custom setting, particularly with logging?

comment:5 Changed 11 years ago by Ryoujin

No, this time Transmission did not crash. Not sure what you mean with custom setting (or logging), but I don't think I have anything special over here.

The computer pretty much has a basic Snow Leopard install (with iStat Menus and clicktoflash), there isn't much installed in the computer (program-wise). I do run Onyx from time to time (at least once a week).

comment:6 Changed 11 years ago by livings124

The list of Console messages relates to the message log window, not the block list. Perhaps see what happens if you use fresh settings.

comment:7 Changed 11 years ago by livings124

Are these still appearing with the latest build?

comment:8 Changed 11 years ago by Ryoujin

Still happening with r10391. Something even more strange happened; when the Message Log bugged when I tried to open About Transmission (to view the build #), if I went to the browser and back to Trasmission, the about dialog would be gone. The Message Log window also bugged.

http://i44.tinypic.com/w6vcjr.jpg

No crash, tho.

Changed 11 years ago by Ryoujin

Console Messages part 1

Changed 11 years ago by Ryoujin

Console Messages part 2

comment:9 Changed 11 years ago by Ryoujin

r10413 still has the Message Log window bug. But, as my last update, the crash doesn't happen when I try to copy the contents of the Message Log.

Changed 11 years ago by Ryoujin

comment:10 Changed 11 years ago by livings124

What happens if you temporarily remove your prefs and app support folder before launching?

comment:11 Changed 11 years ago by Ryoujin

Still happening with r10436. As requested, trashed the .plist files and Transmission's Application Support folder. Just in case, also ran Onyx (Automation, with everything but dyld's shared cache selected) before re-opening Transmission.

By the way, the peers went down to 199,009, and then got back to 224,419 (-25,410). Seems that the value changes over time.

Last edited 11 years ago by Ryoujin (previous) (diff)

Changed 11 years ago by Ryoujin

comment:12 Changed 11 years ago by livings124

This log is from after the config was deleted? Everything was fresh and no torrents were in the newly-launched app?

comment:13 Changed 11 years ago by Ryoujin

Yes, the log was from after the config and app support folders were deleted. Before trying I did re-configure everything as I had it before and added the torrents that I used to have before deleting everything.

Let me try with nothing configured and no torrents. Will report back in a bit, let me delete everything again.

comment:14 Changed 11 years ago by Ryoujin

This is everything I just did:

  1. Trashed again the .plist files and the Transmission folder within Application Support.
  2. Trashed Transmission.app, re-downloaded the latest nightly build (r10436).
  3. Ran OnyX, Automation (with everything but dyld's shared cache selected).
  4. Restarted the computer.
  5. Zapped the PRAM.

As soon as the computer finished restarting, the first thing I did was opening Transmission, going to Preferences > Peers and then tried to download, for the first time, the blocklist. It took me a couple of tries to download it because I got like 2-3 "can't connect to server" or whatever error that has been going on lately, but when I could finally download the blocklist (again, for the first time), the bug showed up.

http://i43.tinypic.com/34ryaub.png

Keep in mind that this is with everything fresh, no torrents, and nothing else from the Preferences modified (other than downloading the blocklist).

Changed 11 years ago by Ryoujin

comment:15 Changed 11 years ago by Ryoujin

No clue about the peers bug, but as for the Message Log window bugging, maybe it can't handle a huge amount of logs and that's why the window bugs out?

The logs I've been attaching are related to the Message Log window bugging when the peers bug shows up.

Last edited 11 years ago by Ryoujin (previous) (diff)

comment:16 Changed 11 years ago by livings124

This ticket covers 2 completely independent issues: the blocklist peers and the message log error. I'm surprised the message log errors still occur with a completely fresh install.

Changed 11 years ago by livings124

comment:17 Changed 11 years ago by livings124

Ryoujin: Can you apply the above patch, and post the corresponding output in Console.app.

comment:18 follow-up: Changed 11 years ago by Ryoujin

How do I apply the patch? (By the way, I'm using r10471)

comment:19 in reply to: ↑ 18 Changed 11 years ago by livings124

Replying to Ryoujin:

How do I apply the patch? (By the way, I'm using r10471)

You check out the source, cd to it, "patch -p0 < /path/to/patch/patch.diff", and build.

comment:20 Changed 11 years ago by Ryoujin

Sorry, got no idea of how to do it. No clue of programming :/

PS: I'm using 10479.

comment:21 Changed 11 years ago by livings124

Ryoujin: try files.me.com/livings124/26lr4n

comment:22 Changed 11 years ago by livings124

Ryoujin: ping

comment:23 Changed 11 years ago by Ryoujin

Sorry for the delay.

The build that was in the link was r10478. Before opening the test build, I trashed the Preferences and the Transmission folder within Application Support. As soon as I opened Transmission I tried to reproduce the error (so nothing else was changed in the Preferences panel). Also, I didn't have anything uploading or downloading.

Started with 224,550 peers. Tried updating for almost 10 minutes, with restarts in between and closing Transmission and re-opening but the peers bug didn't show up. Will try again later tonight when I get home.

comment:24 Changed 11 years ago by livings124

I'm interested in the messages in Console.app when you open the message log, preferably with your previous settings that were causing the problem.

Last edited 11 years ago by livings124 (previous) (diff)

comment:25 Changed 11 years ago by Ryoujin

The huge amount of text that shows up when the peers bug happens is what causes the bug with the Message Log. The first bug, when it happens, it pollutes the Message Log like this http://i40.tinypic.com/2qlet1z.png

So when I try moving around (scrolling up and down and clicking the arrows) in the Message Log, then the Message Log bug appears.

I could reproduce both bugs just now, attaching the log. Keep in mind that this is with the special build you placed. Going back to the latest Nightly Build.

Changed 11 years ago by Ryoujin

comment:26 Changed 11 years ago by livings124

Can you post the console output starting at the message saying libevent thread started?

comment:27 Changed 11 years ago by Ryoujin

Negative.

After I posted the information here I cleared all the logs with Onyx. Been trying to reproduce the bug since this morning up to now to get a new log with the information you asked without luck (as in been spamming the Update Blocklist button almost all day).

Last edited 11 years ago by Ryoujin (previous) (diff)

comment:28 Changed 11 years ago by livings124

Been able to reproduce this yet?

comment:29 Changed 11 years ago by Ryoujin

No, been updating the blocklist randomly for about 2-3 hours. I'll keep trying, as soon as it happens again I'll post the log here.

comment:30 Changed 11 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

Obviously this is a real issue, but you are the only one to have reported this and I lack any usable information to attack it. I appreciate all the tests you have done. Please reopen it if the issue occurs again. I'm going to close for now.

comment:31 Changed 11 years ago by Ryoujin

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Finally.

Something I just noticed is that it seems that the peers bug happens when the blocklist is increased. For example, before trying, I've been keeping an eye and the total IP addresses rules in list were 224,555. After updating, it went down to 199,849. Updated again, and it went to 198,616. Finally, tried to update again and it went to normal 224,557.

Notice that before it was 224,555 and after all the updates it ended with 224,557.

(As soon as the peers bug happened, the Message Log bugged, as mentioned before).

It's also why you will see a bigger sample this time. I'm not deleting the Console messages just in case you need something else, but this time I copied everything, so I shouldn't have left anything out.

Last edited 11 years ago by Ryoujin (previous) (diff)

Changed 11 years ago by Ryoujin

comment:32 Changed 11 years ago by livings124

Was this generated with the patched build I posted?

comment:33 Changed 11 years ago by Ryoujin

Yes, r10478.

comment:35 Changed 11 years ago by Ryoujin

Got it (custom r10528).

If my theory about the peers bug is correct, it will probably take a few days until I can reproduce both bugs, will post as soon as it happens.

comment:36 Changed 11 years ago by Ryoujin

It went down to 203,162, then back to 224,557. Using the patched build you published here.

Changed 11 years ago by Ryoujin

comment:37 Changed 11 years ago by livings124

comment:38 Changed 11 years ago by Ryoujin

Attaching the Console Log from the download you just provided (patched r10528) — Message Log window bug.

By the way, this time the peers went down to 199,849, then back to 224,557.

And I'm not sure if this comment would help but, while Transmission was downloading the blocklist, Little Snitch said that Transmission was connecting to trac.transmissionbt.com.

Last edited 11 years ago by Ryoujin (previous) (diff)

Changed 11 years ago by Ryoujin

comment:39 Changed 11 years ago by livings124

Would it be possible to generate a second report with the same build, to compare them?

comment:40 Changed 11 years ago by Ryoujin

Downloaded r10528 from transmission.xpjets, attaching the log (from the bugged Message Log window).

Peers went to 198,616 and back to 224,557, and it seems that this time the blocklist was downloaded from update.transmissionbt.com.

Last edited 11 years ago by Ryoujin (previous) (diff)

Changed 11 years ago by Ryoujin

comment:41 Changed 11 years ago by livings124

Now see if the issue still occurs with http://files.me.com/livings124/1t3938

comment:42 Changed 11 years ago by Ryoujin

Using the special build you linked a couple of minutes ago.

While the peers bug is not gone, the Message Log no longer bugs, seems that the error messages were replaced. Now I'm also able to copy the contents of it (it didn't allow me before).

The Console log only throws up this

4/26/10 7:44:52 PM	Transmission[638]	special build
4/26/10 7:44:52 PM	[0x0-0x85085].org.m0k.transmission[638]	[19:44:52.660] Starting libevent thread

Here's what the Message Log displays now when the peers bug shows up:

http://transmission.pastebin.com/jSeRmm3y

And it went down to 199,849, then back to 224,557.

comment:43 Changed 11 years ago by livings124

  • Component changed from Mac Client to libtransmission
  • Summary changed from Blocklist bad peers decreases after update, random to Blocklist - bad peers decreases after update; corrupt error messages

Yay. We're getting somewhere.

Charles: There are two issues here. The decreasing number of peers is one. The second is that both of the error messages at blocklist.c lines 282 and 286 are invalid (more than likely rangeBegin or rangeEnd is null or somehow invalid).

Reassigning to libtransmission for now.

Last edited 11 years ago by livings124 (previous) (diff)

comment:44 Changed 11 years ago by livings124

  • Owner changed from livings124 to charles
  • Status changed from reopened to new

comment:45 Changed 11 years ago by livings124

Ryoujin: Can you post what the Message Log displays when the peers bug shows up with http://files.me.com/livings124/wuskw1

comment:46 follow-up: Changed 11 years ago by Ryoujin

Downloaded, but now the peers bug isn't showing up. As soon as it does I'll post back.

By the way, sometimes when I'm updating the blocklist I get

Download of the blocklist failed
Error - The operation couldn’t be completed. (NSURLErrorDomain error -3006.)

This has been happening for a while (weeks ago), also randomly.

comment:47 in reply to: ↑ 46 Changed 11 years ago by charles

  • Component changed from libtransmission to Transmission
  • Owner changed from charles to livings124

Replying to Ryoujin:

By the way, sometimes when I'm updating the blocklist I get

Download of the blocklist failed
Error - The operation couldn’t be completed. (NSURLErrorDomain error -3006.)

This has been happening for a while (weeks ago), also randomly.

This is not a libtransmission error. Nice try livings124. ;)

As for the error messages at blocklist.c lines 282 and 286 -- if you look at the code, you'll see that rangeBegin and rangeEnd are explicitly tested for NULL, so I don't think that's the problem. If they're invalid somehow, could you please provide some more information about the line that's passed in that fails to parse? Otherwise there's not much I can do on this end.

Last edited 11 years ago by charles (previous) (diff)

comment:48 Changed 11 years ago by charles

charles * r10533 libtransmission/blocklist.c: (trunk libT) #3041 "Blocklist - bad peers decreases after update; corrupt error messages" -- better error messages when fed unprintable characters

comment:49 Changed 11 years ago by charles

Ryoujin: any news?

comment:50 Changed 11 years ago by Ryoujin

No, I haven't been able to reproduce the peers bug since the last custom build that livings124 posted; the issue happens randomly, so I've been updating the blocklist from time to time in the mornings and during the night (without luck, yet).

As soon as I get it I'll post back.

comment:51 Changed 11 years ago by Ryoujin

The bug just happened, but it wouldn't allow me to copy the contents of the message log, I think it's because there was too much text (as before). I'm using livings124's special build (the last one he posted over here).

I took a screenshot of what the Message Log displayed: http://i43.tinypic.com/2ylsrah.png

I also got Console Log information (using Pastebin for that as well). Let me know if you prefer the attached logs instead of posting it over there. http://transmission.pastebin.com/4bbX8tSc

When I quit Transmission (while the bug was active) and re-opened, the messages in the Message Log were gone, and after updating the peers it went back to the original value (224,558). I'll keep trying to see if I can, at least, copy a couple of lines that show up in the Message Log (that's if the program allows me).

I'll post back if I find anything new (unless you want me to try something different).

Last edited 11 years ago by Ryoujin (previous) (diff)

comment:52 Changed 11 years ago by Ryoujin

Console Log: http://transmission.pastebin.com/pUbMU98W

Message Log sample

2010-04-29 22:24:35 -0500 blocklist.c:290 [Error] Transmission: error rangeEnd
2010-04-29 22:24:35 -0500 blocklist.c:283 [Error] Transmission: error rangeBegin
2010-04-29 22:24:35 -0500 blocklist.c:290 [Error] Transmission: error rangeEnd
2010-04-29 22:24:35 -0500 blocklist.c:283 [Error] Transmission: error rangeBegin

Screenshot of Message Log window: http://i40.tinypic.com/11ah3c9.png

Couldn't get anything else because as soon as I tried to scroll the Message Window to see if there were different messages it bugged.

This time the total IP address rules in list went the lowest I've seen so far, 1,235. After updating again it went back to 224,558.

comment:53 Changed 11 years ago by Ryoujin

Tried with one of the most recent nightly builds (r10554), no Message Log window bug, I got these messages:

2010-04-30 17:04:55 -0500 blocklist.c:280 [Error] Transmission: skipping line #220482 which contains nonprintable characters
2010-04-30 17:04:55 -0500 blocklist.c:280 [Error] Transmission: skipping line #220546 which contains nonprintable characters

Whole thing here: http://transmission.pastebin.com/QcZiPCF2

Peers went to 223,758, updated at least five times in a row and it remained there. Then I used the last custom build that livings124 posted and it went back to the original value (224,558).

comment:54 Changed 11 years ago by livings124

Ryoujin: Give r10558 a try. If there are any issues please post the corresponding Console.app log and message log lines.

Last edited 11 years ago by livings124 (previous) (diff)

comment:55 Changed 11 years ago by Ryoujin

Finally.

I'm using r10623 (I'm guessing it's fine because it also has the patch that r10558 had). This time the peers went up by a decent number, 224,870 (+312 peers), from the old 224,558. Updating the blocklist again placed it back to the original value.

The Message Log had this

2010-05-02 11:32:42 -0500 blocklist.c:288 [Error] Transmission: blocklist skipped invalid address at line 313

And Console.app

5/2/10 11:31:59 AM	[0x0-0x5c05c].org.m0k.transmission[543]	[11:31:59.780] Starting libevent thread
5/2/10 11:32:50 AM	[0x0-0x5c05c].org.m0k.transmission[543]	error rangeBegin: Freddie Mac FREDDgAman:4.22

By the way, these messages are really annoying :P They have been popping up a lot more than before.

Download of the blocklist failed.
Error - The operation couldn’t be completed. (NSURLErrorDomain error -3006.)

comment:56 Changed 11 years ago by livings124

Hmm, that's strange. Does the error message (the last one you posted) correspond the when the number increases (or does it decrease?), and does it correspond to those console messages? Can you give r10624 a spin?

comment:57 Changed 11 years ago by Ryoujin

Yes, both Message Log and Console.app error messages correspond the when the number of peers increased (to 224,870).

This is what I do

  1. I update the blocklist randomly from time to time several times in a row, then I try later until the bug shows up.
  2. As soon as it shows up I open the Message Log, which is already showing up the error.
  3. Then I open Console.app and filter it, afterwards I copy whatever shows up within the time frame the bug appeared.

I'll give r10624 a try as soon as it gets pushed into transmission.xpjets (saw it in build.transmission, but my client checks the first one). As soon as it happens again I'll post.

comment:58 Changed 11 years ago by livings124

Ryoujin: anything to report?

comment:59 Changed 11 years ago by Ryoujin

Nothing to report yet.

Yesterday I thought it happened because the peers jumped from 224,559 to 224,576, but it was a normal increment (no error, and I updated several times afterwards and it remained there). I'm using r10629.

Since the last time I posted I've been trying during the morning, afternoon and night. If you want you can probably close this for now, and if it happens again I'll post (as what we did the last time).

comment:60 Changed 11 years ago by livings124

  • Milestone changed from None Set to 1.93
  • Resolution set to fixed
  • Status changed from new to closed

I'm going to mark this as fixed for now. Please reopen if you can replicate it again. Thanks for all your help Ryoujin!

Note: See TracTickets for help on using tickets.