Opened 11 years ago

Closed 11 years ago

#3042 closed Enhancement (fixed)

Can't do context menu actions with multi entries in web interface

Reported by: albb0920 Owned by: albb0920
Priority: Normal Milestone: 2.00
Component: Web Client Version: 1.91
Severity: Normal Keywords: patch-needed
Cc:

Description

As title. I upgrade my transmission these days and I found this problem in the latest version. When I multi-select entries and right click, every entries except the first one will become unselected. I tried comment out line 308 of transmission.js

tr.setSelectedTorrent( $(e.target).closest('.t orrent')[0]._torrent, true );

and the problem is fixed. So I'm wondering this is a Bug or a feature. XD

Attachments (1)

multisel.patch (540 bytes) - added by albb0920 11 years ago.
patch to support mutl-entries without losing the behaviar of setting mouse pointed entry as selected

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by kjg

  • Keywords patch-needed added
  • Type changed from Bug to Enhancement

It looks like this is intentional, but I'm not attached to this behaviour. If someone would like to write a patch to make it work for multiple-selected torrents, feel free.

Changed 11 years ago by albb0920

patch to support mutl-entries without losing the behaviar of setting mouse pointed entry as selected

comment:2 Changed 11 years ago by albb0920

I hope this patch helps. Cheers!

comment:3 Changed 11 years ago by livings124

  • Milestone changed from None Set to 2.00
  • Owner kjg deleted

Thanks! r10378

comment:4 Changed 11 years ago by livings124

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 11 years ago by Robby

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:6 Changed 11 years ago by Robby

  • Owner set to albb0920
  • Status changed from reopened to new

comment:7 Changed 11 years ago by Robby

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.