Opened 12 years ago

Closed 12 years ago

#3052 closed Bug (duplicate)

download drive disconnected has BAD side effects

Reported by: megabulk Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.92
Severity: Major Keywords:
Cc:

Description

My download folder is on an external drive. In the past, starting Transmission with the external drive disconnected was mildly inconvenient. Now it's a disaster. Previously, Transmission would ask me for a new download location for every single one of my torrents. I'd work around this problem by force-quitting, connecting the external drive, and re-starting Transmission. But now, every single one of my torrents needs its data re-checked. Worse, some of my downloaded/seeding torrents seem to have become corrupted, and Transmission begins downloading them again; in most cases, it's a single chunk that's corrupted, but in some cases, it's the entire file.

So, a recipe: with your download folder on an external drive, download some torrents. Seed them. Quit Transmission. Disconnect the external drive. Start Transmission. Quit Transmission. Reconnect the external drive. Restart Transmission. See all of your downloads need to be re-verified. See some of them be partially or totally corrupted.

I just tried the latest stable build (10389) and the problem persists.

Change History (3)

comment:1 Changed 12 years ago by charles

This appears to be a duplicate of #2955

comment:2 Changed 12 years ago by charles

  • Version changed from 1.92+ to 1.92

comment:3 Changed 12 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.