Opened 12 years ago

Closed 12 years ago

#3057 closed Bug (wontfix)

Transmission reports inaccurate throughput when manipulating system date/time during download.

Reported by: lowell Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.92
Severity: Normal Keywords:
Cc:

Description

Summary

Transmission reports inaccurate throughput when system date/time is changed to a past date/time.

Steps to Reproduce

  1. Launch Transmission
  1. Open a .torrent file and begin downloading.
  1. Note the transfer speed.
  1. Change the system date to any past date or time.
  1. Note the rising transfer speed.

Expected Results

None; didn't expect changing the system date & time would affect a torrent client.

Actual Results

Transmission reports the throughput incorrectly. My home internet's maximum connection speed is ~100 kb/s; if I let Transmission download for a few minutes with an incorrect system date, the throughput will exceed my maximum and continue to climb - it reached 20 Mb/s during my most recent experiment.

Here is a video demonstrating the bug: http://www.youtube.com/watch?v=1ufN_LJW1pw&fmt=22

The video uses Transmission 1.9.1, but the bug is also in 1.9.2.

Workaround

Allow Mac to automatically set the date and time.

Regression/ Isolation

This occurs only when rolling the date backwards, and will occur when the date is changed to as little as one minute prior to the real time. Also, the date change must occur while the torrent's target is downloading in order to reproduce.

System is Mac OS X 10.6.2; Transmission 1.9.2.

Notes

http://trac.transmissionbt.com/ticket/2025 reports similar behavior, though it doesn't appear to be caused by date/time manipulation.

Attachments (2)

Screen shot 2009-03-17 at 12.51.33 AM.png (37.8 KB) - added by lowell 12 years ago.
Transmission main window
Screen shot 2009-03-17 at 12.51.24 AM.png (106.4 KB) - added by lowell 12 years ago.
Transmission inspector

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by lowell

Transmission main window

Changed 12 years ago by lowell

Transmission inspector

comment:1 Changed 12 years ago by livings124

  • Resolution set to wontfix
  • Status changed from new to closed

The fix for this is worse than the actual issue.

Note: See TracTickets for help on using tickets.