Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3062 closed Bug (invalid)

Transmission downloads low priority files first

Reported by: nickshanks Owned by: charles
Priority: Normal Milestone: None Set
Component: libtransmission Version: 1.92
Severity: Normal Keywords:
Cc:

Description

Summary: When downloading a multi-file torrent, with one file set to high priority, one left at medium priority, and one set to low priority, they will download in the order High, Low, Medium.

Case: I started downloading a large multi-file torrent yesterday. Late in the evening, when all files were at 20%, I set the first directory to high priority, and the third to low, and left it overnight. When I woke this morning, the first directory had completed, the second was still at 20% and the third was at 80%. The torrent has 8 seeds and one other leech, so this was not an availability issue. Note, this bug is not #2968, as transfer had already commenced before priorities were set.

Change History (5)

comment:1 Changed 11 years ago by livings124

  • Component changed from Mac Client to libtransmission
  • Owner changed from livings124 to charles

comment:2 Changed 11 years ago by charles

I'm not able to reproduce this behavior.

How large are the three directories when done?

comment:3 Changed 11 years ago by nickshanks

There were five directories each containing approximately twenty 700 MB files (totalling between 13.2 and 13.8 GBs per dir), the bottom two were turned off at the same time as I changed the priorities.

comment:4 Changed 11 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

Okay, I've tried a handful of tests now and am still not able to reproduce these results. Unless this is reproducible I'm going to chalk it up to chance.

comment:5 Changed 11 years ago by nickshanks

That's fine. I have only seen it in my latest torrent using the 1.92 release. I thought it might have been something recently introduced, but if it doesn't ring any bells and you can't reproduce it, nothing more can be done. If I see it clearly the next time I download something, and can reproduce it every time, I will re‐open this bug.

Note: See TracTickets for help on using tickets.