Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3067 closed Bug (duplicate)

When selecting files to download in a torrent, Transmission downloads everything.

Reported by: tehKitten Owned by: kjg
Priority: High Milestone: None Set
Component: Web Client Version: 1.92
Severity: Major Keywords:
Cc:

Description

I have this problem with a large torrent. (120GB+, more than 300 folders, and more than 5000 files) First I added the torrent paused, then I deselected everything, and ticked the boxes of a few files, in total like 100mb. Then I started the torrent, and Transmission starts to download. Then when over 400MB downloading, the files I selected were downloaded all 0 bytes downloaded, and some non-selected files were downloaded. Transmission ignores the selection of files.

This is all through the Web UI. (It's a seedbox. The normal Download/Upload? is ok.) Excuse me if I made any mistakes in my English.

Change History (10)

comment:1 follow-up: Changed 12 years ago by charles

This sounds like a duplicate of #532, but I'll leave it open until someone else can confirm that selective downloading works in the web client, at least up to the constraints of #532

comment:2 in reply to: ↑ 1 Changed 12 years ago by tehKitten

Replying to charles:

This sounds like a duplicate of #532, but I'll leave it open until someone else can confirm that selective downloading works in the web client, at least up to the constraints of #532

It is not, that is the blocks problem, I understand that, but with this problem, it doesn't download the blocks of the files I want.

comment:3 follow-up: Changed 12 years ago by livings124

I cannot replicate this. Are you sure it's not #532? Do the checks change in the ui when you change it in the web interface? Is it repeatable for multiple transfers?

comment:4 in reply to: ↑ 3 Changed 12 years ago by tehKitten

Replying to livings124:

I cannot replicate this. Are you sure it's not #532? Do the checks change in the ui when you change it in the web interface? Is it repeatable for multiple transfers?

I don't have access to the actual UI, so I wouldn't know if it actually changed. (Probably not, because it keeps downloading the wrong files.)

This is the actual files in the torrent. (I asked the uploader)

~137,177,370,719 bytes, ~21,064 files, ~3,051 folders.

It's a little bit more then I said first.

comment:5 Changed 12 years ago by livings124

I do not understand what you are saying. How many files did you selected, how many were downloaded? Are you sure data wasn't downloaded before you deselected? Are you sure it's not #532 (were the files that appeared around the ones you selected)? How big were the files you selected?

comment:6 Changed 12 years ago by tehKitten

I selected the files of 1 folder, that folder was like 400MB. After transmission downloaded more then 2GB, I stopped him. At that moment, the selected files were 0bytes, and some non selected a few KB. (A few KB each in 20k+ files, makes 2GB fast)

I add the torrents paused, then selected the files, and then started it.

If I would download everything, there would be no problem.

comment:7 Changed 12 years ago by livings124

This sounds like #532 - you say each file is only a couple of kb's each, which implies it's just the unwanted but received data. Read the first few posts on that ticket. Can you replicate this on other torrent files without so many files?

comment:8 Changed 12 years ago by tehKitten

Well, never mind. You won't understand, and there are almost no people who want to download torrents this big, with transmission's webui. Let's see if I can close it, if not, it can be deleted by a moderator or something.

comment:9 Changed 12 years ago by tehKitten

  • Resolution set to duplicate
  • Status changed from new to closed

comment:10 Changed 12 years ago by bascorp

spam removed

Last edited 12 years ago by livings124 (previous) (diff)
Note: See TracTickets for help on using tickets.