Opened 14 years ago

Closed 13 years ago

#307 closed Enhancement (fixed)

inhibit/prevent hibernation when downloading

Reported by: zcrar70 Owned by: charles
Priority: Normal Milestone: 1.20
Component: GTK+ Client Version: 0.80
Severity: Normal Keywords:
Cc:

Description

uTorrent has a nice feature which prevents the computer from shutting down when a torrent is downloading/uploading. Transmission should really implement this too; it's confusing to find the PC powered down with only 1% of the torrent downloaded when you'd expect it to only power down once the torrent has finished downloading/uploading (when the desired ratio is reached for example).

Gnome has some info about how to implement calling the Inhibit()/Uninhibit methods to prevent hibernation during this kind of operation: http://cvs.gnome.org/viewcvs/*checkout*/gnome-power-manager/src/gpm-inhibit-test.c. It might be possible to add this as an option if it isn't the default behaviour.

Change History (7)

comment:1 Changed 14 years ago by charles

  • Milestone changed from 0.81 to None Set

comment:2 Changed 14 years ago by charles

  • Summary changed from Transmission should inhibit/prevent hibernation when downloading (GTK) to inhibit/prevent hibernation when downloading

comment:4 Changed 14 years ago by charles

  • Milestone changed from None Set to 1.20
  • Owner set to charles
  • Status changed from new to assigned

http://mail.gnome.org/archives/svn-commits-list/2008-January/msg04872.html has a straight code example of how nautilus-cd-burner does this.

comment:5 Changed 14 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

Added to r5605.

comment:6 Changed 13 years ago by kiddo

  • Resolution fixed deleted
  • Status changed from closed to reopened

This will need to be re-worked on slightly for the gnome >=2.26 releases, as the functionality is being moved into gnome session: http://blogs.gnome.org/hughsie/2009/01/28/inhibits-and-the-new-world-order/

The problem is that I can't seem to find documentation to point you to other than the announcement.

comment:7 Changed 13 years ago by livings124

  • Resolution set to fixed
  • Status changed from reopened to closed

Can you open a new ticket when more information is available? Thanks!

Note: See TracTickets for help on using tickets.