Opened 12 years ago

Closed 12 years ago

#3073 closed Bug (invalid)

CLI documentation clarifications needed

Reported by: RichardNeill Owned by:
Priority: Normal Milestone: None Set
Component: CLI Version: 1.92
Severity: Normal Keywords: cli documentation seed trackerless
Cc:

Description

The transmissioncli documentation is somewhat sparse: one man page and no online userguide.

For example, the man page doesn't actually say how you should seed a new torrent. (It's obvious after the fact, but when I started, why would I expect to put the file I want to publish into my *download* directory)

Also if I create a trackerless torrent (without the -a) option, then I can start seeding it, and give the .torrent to another machine, but how is the second machine supposed to know where to find the seeder? This isn't documented anywhere that I can find, and it leaves me rather puzzled?

It would be nice if transmission-cli had some documentation on how to use it as a substitute for scp (as a simple example). For instance, the following would be an ideal starting point for the man page (except that it doesn't actually work, and I don't know why):

On machine "seed" (192.168.0.1), create a sample file:

mkdir download_dir echo "Hello World" > download_dir/hello.txt

Then create a trackerless torrent:

transmissioncli -n download_dir/hello.txt hello.torrent

Start this seeding:

transmissioncli -er -w download_dir hello.torrent

On machine "client" (192.168.0.2), get a copy of hello.torrent (via scp/rsync/http/whatever)

Start client downloading:

transmissioncli -er -w download_dir hello.torrent

The problem is that "client" has no way to know that it should look at 192.168.0.1 to start building a DHT...and the answer to how it should find out would be really really nice to have in the man page!

Thanks - Richard

P.S. Another really useful document to have would be how to use transmission as a substitute for multiple instances of rsync.

Change History (2)

comment:1 Changed 12 years ago by Longinus00

I've already responded to your question in the forum but I'd like to point out that transmisison-cli is being depreciated in the future. Also, bitorrent is a poor substitute for rsync if you're trying to send file deltas instead of whole files.

comment:2 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

Longinus00's two points about transmission-cli's future and BitTorrent?'s suitability as an scp substitute are dead-on. I'd also add that, even if transmission did have an expansive user manual, these fringe use cases would not be covered in them.

Note: See TracTickets for help on using tickets.