Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3078 closed Bug (fixed)

Transmission closes socket after SIGHUP

Reported by: Altimit Owned by: charles
Priority: Normal Milestone: 1.93
Component: Daemon Version: 1.92
Severity: Normal Keywords:
Cc:

Description

How to reproduce:

server# sockstat | grep trans
root     transmissi 53026 9  tcp4   *:9091                *:*
root     transmissi 53026 10 tcp4   172.16.64.4:51413     *:*
root     transmissi 53026 11 tcp6   *:51413               *:*
root     transmissi 53026 12 dgram  -> /var/run/logpriv

server# kill -s HUP 53026

server# sockstat | grep trans
root     transmissi 53026 9  tcp4   *:9091                *:*
root     transmissi 53026 12 dgram  -> /var/run/logpriv

Change History (6)

comment:1 Changed 11 years ago by assar

I have the same problem, also with 1.92, even though I've never seen it work properly when using SIGHUP for reloading blocklists. I did not use SIGHUP before the blocklist reloading was implemented so I can't say if the problem was there before.

I'm using Arch Linux and started using Transmission during version 1.80 or something. Now with the --blocklist-update option for transmission-remote this is not really a big problem for me any more, but since the daemon can be signalled with SIGHUP to reread the conf file, it may cause annoyances.

EDIT: Disregard my comment about this not being a problem for me with the --blocklist-update option. It seems --blocklist-update and SIGHUP don't do the same thing; --blocklist-update reads the level1 blocklist from update.transmissionbt.com, while I thought it reread the blocklist I already have. So, the only way for me to force a reload of the blocklist _I've_ specified, is to use SIGHUP, which kills the listening socket.

Last edited 11 years ago by assar (previous) (diff)

comment:2 Changed 11 years ago by charles

  • Milestone changed from None Set to 2.00
  • Owner set to charles
  • Status changed from new to assigned

r10538 seems to fix this. could you test out a new build?

comment:3 Changed 11 years ago by Altimit

It works

comment:4 Changed 11 years ago by charles

  • Keywords backport-1.9x added
  • Resolution set to fixed
  • Status changed from assigned to closed

comment:5 Changed 11 years ago by assar

Yes, confirmed here too, great! (Hope I'm not opening this ticket again now...)

comment:6 Changed 11 years ago by charles

  • Keywords backport-1.9x removed
  • Milestone changed from 2.00 to 1.93

backported to 1.9x in r10568

Note: See TracTickets for help on using tickets.