Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3079 closed Enhancement (wontfix)

Show ratio for downloads

Reported by: Egil Owned by: kjg
Priority: Normal Milestone: Sometime
Component: Web Client Version: 1.92
Severity: Trivial Keywords: ratio, download
Cc:

Description

I like to know the ratio of my active torrents, whether they seed or not. If it is a design desition not to show it, that's ok, but here is a trivial patch in any case more users beside me likes it. Its a crude copy and paste patch, but it does the job.

Attachments (1)

show_ratio_for_downloads.diff (216 bytes) - added by Egil 12 years ago.
show ratio for downloads as well as seeds

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by Egil

show ratio for downloads as well as seeds

comment:1 Changed 12 years ago by Egil

the patch is for web/javascript/torrent.js

comment:2 Changed 12 years ago by livings124

I appreciate the patch, but I'm pretty sure this is by design to not show too much info in each row.

comment:3 Changed 12 years ago by livings124

  • Resolution set to wontfix
  • Status changed from new to closed

comment:4 Changed 12 years ago by User294

To be honest, I somewhat dislike current web UI design:
It occupies quite much vertical space per torrent entry. Especially, each torrent entry is large by it's height. This makes navigation quite hard if you have more than some ~20-30 torrents or so. But while each torrent entry large, it shows very few useful info. So it's huge ... for nothing. I believe this can be improved.

As for me I can admit:
1) I do not like or need need such a huge progress bars. I hate them. They waste lots of on-screen space but are useless because update granularity definitely not 1 screen pixel. So they can be reduced by several times without losing any information.
2) Yes, I want to see more information on Transmission web face. Running seedbox as half-blind kitten is not very pleasant experience.

Btw same applies to GTK compact view partially. As it also haves same useless huge progress bars which are updated by large jumps rather than by each and every pixel so they're wasting lots of screen space for nothing and compact view is not informative enough to get idea on current activity and overall state, etc.

P.S. sorry if this sounds harsh, that's just attempt to point to things I dislike in Transmission UI. I believe it's possible to make UI several times more compact without losing any information which is currently displayed. This could improve usability for people who downloads or seeds many torrents at once. For example: I'm seeding over 60 torrents from Jamendo.com, etc. Navigating through them is a somewhat PITA.

Last edited 12 years ago by User294 (previous) (diff)

comment:6 Changed 12 years ago by User294

Am I understand correctly that this is "alternate" Web UI?
Also I can see, now compact mode much more compact in GTK+, I seems to really like how it looks so I'm a bit slow with building SVN version for me :)

comment:7 Changed 12 years ago by livings124

That is the future web ui that will be built in.

Note: See TracTickets for help on using tickets.