Opened 11 years ago

Closed 11 years ago

#3083 closed Bug (duplicate)

Transfer rate indicators sometimes increase linearly with time

Reported by: glinsvad Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.92
Severity: Minor Keywords: gui, indicator, rate, speed
Cc:

Description

I've notice that both the total transfer rate and the rates for individual torrents sometimes become astronomical and keep increasing over time. I'm currently watching a 100 MB torrent download at an alleged (and increasing) rate of 67 MB/s which is clearly due to some form of bad arithmetic.

Limiting the download rate to say 5kb/s makes no difference in terms of the displayed rate, but of course still works as intended as far as I can tell.

This phenomenon is persistently occurring once Transmission has been running for a couple of hours but sometimes rectifies itself after a while with ludicrous speeds. The transferred file sizes are always correct, which must mean that the error lies in the time measurement and/or division. Likewise, the ETA is also correct.

Change History (1)

comment:1 Changed 11 years ago by glinsvad

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #2025, sorry.

Note: See TracTickets for help on using tickets.