Opened 7 years ago

Closed 7 years ago

#3085 closed Bug (invalid)

Transmission 1.92 crashes often requiring lengthy re-verification of local content

Reported by: BSartist Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.92
Severity: Major Keywords: crash stalled verify
Cc: krx@…


I downloaded and installed 1.92 of Transmission for the Popcorn Hour A-110.

But I am finding something that is making it almost unusable - almost.

It seems to crash and restart every so often. It has happened when adding or pausing a torrent but it also happens on its own. I only know this because my browser window running the client gets a messaging saying it lost the connection. Upon refresh I see all my active torrents waiting to perform a local verify (with one of them verifying of course).

These verifies take a long time. Sometimes one of them will get stuck at a certain percent and pause and restart does not work. I had to delete all the downloaded content on one torrent and start all over. Frequently, the verify will stop at 100% and not let the ones waiting start their verification. I have to pause the 100% one and then the others will go.

I looked around in the transmission directories (including the .transmission hidden one) for logfiles indicating a cause for the crash but could not find anything.

Anyone experiencing this? Have any suggestions for improving stability? Should I post this elsewhere? How can I get more information to help out whoever might want to debug this? Like a trace or dump?

Change History (9)

comment:1 Changed 7 years ago by charles

Is gdb available on the A-110? How are applications usually debugged there?

comment:2 Changed 7 years ago by BSartist

  • Summary changed from Transmission 1.91 crashes often requiring lengthy re-verification of local content to Transmission 1.92 crashes often requiring lengthy re-verification of local content

First, I apologize for misstating the version in the title. I am indeed talking about 1.92

I am not a developer on the NMT platform so I can't answer your question but I might try posting it over there to see if someone bites.

Truth be told, I am now finding the stalled verifies MUCH more debilitating than the actual crash. Maybe I should put a separate ticket. I'm now finding that after a very long time verifying a couple gigs of data it stalls at some random % and the only fix is to remove and re-add the torrent thus starting the whole verify again. Seems to be happening on more verifies than not.

comment:3 Changed 7 years ago by krx

Is your transmission daemon responding to the query/change commands (command line/webclient) while veryfying? Even in the "stuck verify" situation?

comment:4 Changed 7 years ago by krx

  • Cc krx@… added

comment:5 follow-up: Changed 7 years ago by BSartist

Yes. The daemon responds to all commands from the web interface.

All other ops seem normal. To wit:

Non verifying torrents continue to download. Pause and resume work on all torrents. When the stuck torrent is paused, it pauses and the next one waiting starts to verify.

I have also paused all and stopped and restarted the daemon. While it restarts and continues as above, it won't shake the stuck torrent loose.

comment:6 Changed 7 years ago by BSartist

Oh. And when I resume the stuck torrent it comes back to verifying but still stuck.

I can't be sure it always resumes at the same % when At least once I saw it resu e at a lower percent and stick. Maybe 10 or 20% less.

comment:7 in reply to: ↑ 5 Changed 7 years ago by krx

Replying to BSartist:

Yes. The daemon responds to all commands from the web interface.

Then it is not my case, from 1st description I might have had assume, that issues are related.

I would recommend running transmission daemon in foreground mode to check for any warning/error/info/debug messages.

comment:8 Changed 7 years ago by BSartist

I've looked into the scripts that start the app and it looks like both stdout and stderr are redirected to a file called .daemonresult but the only message I see in that file are "Started OK" or somesuch.

In the meantime, trying to use clutch to talk to the daemon is a hot mess. Hangs sometimes, looses connection. Sometimes the files are re-verifying upon return but sometimes not.

I tried running the daemon on the command line but it doesn't seem to start up the right way.

Sadly I think I have to throw in the towel on this. I am spending more time handholding than enjoying the results. I don't even know how to get V1.91 installed on the Popcorn Hour but I know that's not your issue.

comment:9 Changed 7 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

The lengthy re-verification issue is already being addressed by #2955.

The other half of this ticket is IMO the crash, but so far there are still no more details on that. If you have more information available, please reopen this ticket along with details about the crash. Thank you!

Note: See TracTickets for help on using tickets.