Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#3087 closed Enhancement (duplicate)

Pause other healthy torrents while verifying dirty one's option on the startup

Reported by: krx Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.92
Severity: Normal Keywords:



I have and issue, which either I unable to issolate or the issolation will not find viable solution due to the problems in the HW. The problem is that if there is a bigger list of torrents (40+ at least in my case), most of them in the seed or the download mode, and at least one in dirty mode, after startup very high I/O (CPU from at least 2.5..3, and I was able to see even 7..9 range) for both verify and seed/download transactions either aborts the transmission due to memory too low on Asus WL-500GPv2, or hangs the router, repeating this viscious cycle over and over again.

The manual workaround, which works in effect, is to quickly stop all other non-verifying torrents just after startup, letting the verify tasks to finish, one by one, - if there are few. After this unpausing/starting torrents lets the Transmission to work stably until next unexpected reboot due to external reasons. I know, that this is agains the good practice to solve direct underlying problems, but I think, this would be of great help.

Therefore the option in the settings file like "Don't start (/unpause) the torrents until the verify tasks finish on the startup" would be helpfull.

Change History (2)

comment:1 Changed 8 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

IMO #2955 addresses the same problem being addressed by this suggestion. It's one a direct duplicate, but implementing #2955 will solve this issue too.

comment:2 Changed 8 years ago by krx

OK, I see. You got into quite technical discussion on #2955, we will wait ant see, what come from this one. Regards!

Note: See TracTickets for help on using tickets.