Opened 8 years ago

Closed 8 years ago

#3110 closed Bug (worksforme)

Transmission disables AirPort when Speed Limit is on.

Reported by: godDLL Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.92
Severity: Normal Keywords:


Reproduced three times over the course of two and a half hours on my machine, with one seeding and one downloading torrent and Speed Limit on – both torrents are private, the downloading one set to 150 maximum connections.

user ~$ /Users/user/Applications/ 
[16:23:47.720] Starting libevent thread
2010-04-01 16:23:48.778 Transmission[832:903] SizeWell (SIMBL plugin) loaded into NSApplication
connect: Operation timed out

At this point it becomes unresponsive in the GUI, but can be killed with Control-C just fine.

01/04/2010 4:58:10 PM	kernel	vmnet: Failed to shallow copy mbuf: 12.

This really is the only hint I have, this message from VMware tap/tun for virtual machines appears consistently after Transmission hangs and disables AirPort?. AirPort? functionality can only be recovered by rebooting the system.

Macmini2,1 MacOS X v10.6.3 (10D573), with Transmission 1.92 from the app-cast update. Version 1.91 didn't exhibit this behaviour. I'm going to test the nightly now, and post further developments.

Attachments (1)

Screen shot 2010-04-01 at 5.06.59 PM.png (39.7 KB) - added by godDLL 8 years ago.
Icon looks like there is connection, but no checkmark next to a BSSID; the network interface can't be brought back to life.

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by godDLL

Icon looks like there is connection, but no checkmark next to a BSSID; the network interface can't be brought back to life.

comment:1 Changed 8 years ago by livings124

It looks like your system and/or network can't handle the network load. You need to limit the speed. I don't think there's much we can do about this issue.

comment:2 Changed 8 years ago by godDLL

I've been testing the same configuration with 1.92+ (10433) for a day, and different load scenarios for a the last three or so. I can't reproduce the AirPort? behaviour.

I haven't seen this kind of silent failure anywhere in the OS before. Can you think of anything I can do, any tests I can run to pinpoint this issue? This kind of thing really spooks me.
Maybe I should build a debug target of 1.92, and give it a run with Instruments attached, or something. Give me some ideas, I'm really lost as to what the issue could be.
Maxing out the system/network hardware on a 2500/250 Kbps connection does not seem too likely to me.

comment:3 Changed 8 years ago by livings124

Testing with instruments sounds like a good idea. It might not be the speeds, but the number of connections maxing it out. Have you changed the default number of peers to connect to? The error message you listed above does appear to be related to how the system handles "high tcp load applications."

comment:4 Changed 8 years ago by godDLL

In my original case there were two torrents in the queue, one seeding (50) and one downloading (150 connections). My ISP supposedly caps me at 200 (can't really test that). I've had ~200 peers many times before, and my set-up (hardware, ISP) hasn't changed in at least six months. It might be some sort of an edge case for one of the things in the chain, I don't have any idea where to start looking even.

What sucks for me is that I can't build debug versions of AirPort? kernel extensions and watch the debug output of that. I'll try poking around with Instruments over the coming few days.

comment:5 Changed 8 years ago by charles

Is there any news on this ticket?

comment:6 Changed 8 years ago by jch

When this next happens, please run "netstat -apn" (or whatever the Mac OS equivalent is) and let us know whether you're seeing a lot of connections in a weird state (i.e. anything else than "CONNECTED").

comment:7 Changed 8 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

Please reopen if there's more information. With what we have now, it looks like it's a network configuration issue.

Note: See TracTickets for help on using tickets.