Opened 12 years ago

Closed 12 years ago

#3124 closed Bug (duplicate)

Unrealistic UL/DL speeds display (sometimes freezing the application).

Reported by: Mosstromo Owned by: livings124
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.92
Severity: Minor Keywords: Unrealistic speeds, wrong speeds, extreme speeds, false speed display
Cc:

Description

Transmission 1.92 (10363)
Mac OSX 10.5.8

Event's date:
April 04, 2010, estimated start time 14:00 hrs. +7 GMT
April 04, 2010, estimated stop time NEVER (manually disengaged after aprox. 1 hour).

Event's description:
Suddenly the speeds of uploads and downloads shown on the application become unrealistic. (See attached pics).
No warning nor special conditions apparent.
Out of 3 cases within (aprox.) a month, in 2 ocassions the application stopped uploading and downloading.
Transmission did not freeze or stop functioning completely. Application responded normally to user input (such as pausing activity and closing the application).
In 1 ocassion it continued UL and DL at its correct speed but displaying false speeds in both UL and DL.

Tests during the event:
1) With speed limits enabled and without speed limits the conditions remain the same: False display of speed.
2) Uploading speed and downloading speed affected similarly.
3) All of the torrents affected by false display at the time where from the three same locations (3 unique IP addresses). Others were unaffected. (See attached pic 02).
4) Speed is not truly increased, only the display of the speed.
5) Condition persists with multiple torrents open or just the 3 torrents presenting the annomaly.
6) Condition persists even with only one torrent selected, active and downloading.
7) Wrong data information persists in Dock Icon after pausing and restarting torrents (without quitting application). It does not persist in Transmission's Inspector Window (See attached pic 01).
8) Displays data of active download eventhough no peers are present. (See attached pic 03).

Recipe:
No recipe on how to recreate event, the bug appears spontaneously and my programming knowledge is extremely limited. (I know certain conditions must exists, but what I mean is that those conditions could not be observed normally, so far).

Attachments (4)

false_speed_display.jpg (190.3 KB) - added by Mosstromo 12 years ago.
False speed displays.
02_inspector_window_display.jpg (27.0 KB) - added by Mosstromo 12 years ago.
Inspector display showing false Mb upload.
03_full_app_display.jpg (192.6 KB) - added by Mosstromo 12 years ago.
Displays showing false DL/UL speeds and remaining times.
01_dock_display.png (51.2 KB) - added by Mosstromo 12 years ago.
Dock stuck showing false DL/UL speeds.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 12 years ago by livings124

  • Component changed from Mac Client to Transmission

Changed 12 years ago by Mosstromo

False speed displays.

Changed 12 years ago by Mosstromo

Inspector display showing false Mb upload.

Changed 12 years ago by Mosstromo

Displays showing false DL/UL speeds and remaining times.

Changed 12 years ago by Mosstromo

Dock stuck showing false DL/UL speeds.

comment:2 Changed 12 years ago by Mosstromo

  • Keywords false added

comment:3 Changed 12 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

This appears to be a duplicate of #2025. Closing this one in favor of the existing ticket.

Note: See TracTickets for help on using tickets.