Opened 12 years ago

Closed 12 years ago

#3130 closed Bug (duplicate)

Transmission could fail to use high-bandwidth links in some scenarios (==transmission is slow).

Reported by: User294 Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.92+
Severity: Major Keywords:
Cc:

Description

Special conditions:

  1. You need a really high-bandwidth link to Internet. At least 20Mbits/s upload speed is a must to reproduce this in a realiable way. I used 30MBps symmetric link during tests. Make sure your ISP does not trottles BitTorrent? as well.
  2. Assuming clear default configuration - no torrents added.
  3. Popular torrent needed (you can try Ubuntu iso files, free movies, etc). The only thing we need ia enough leechers (~100 or so).



To reproduce:

  1. Add one popular torrent to transmission.
  2. Download it. Notice download speed (usually close to channel capacity for good swarm and popular torrent)
  3. Take a look what happens when seeding.


Result:

I can see at most 15 leeching peers connected, regardless of number of leechers advertised by tracker and known peers who may want to download. Other leeching peers are not connected for some reasons. Just 15 peers actually fail to saturate 30Mbps link (they're just unable to consume all bandwidth). In fact, link is used only by 15-30% of it's capacity in such scenario most of times, no matter how many downloaders are there. I guess this is what makes people with high bandwidth links to claim "transmission is slow". It really is. I can suggest to allow more leeching peers connections if one or very few active torrents are here and fast link. Maybe this should be adjustable or so. I found no obvious controls in UI to improve speed in such scenarios and hence, users would fail to find them as well I guess.


NB: this issue could affect reasonable amount of users, actually. In some countries there is Metro Ethernet widely used so 30 and even 50Mbps links to internet are not something uncommon. I guess now I know why I heard some mumblings that Transmission is slow.

Change History (1)

comment:1 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of ticket #2997

Note: See TracTickets for help on using tickets.