Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3134 closed Bug (worksforme)

transmission-remote apparently can't handle "'" in errorStrings

Reported by: mtu Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 1.92
Severity: Trivial Keywords: needinfo
Cc:

Description

[21:22:24.676] JSON parser failed at line 1, column 970: "VW'*C","eta":26"

relevant segment: {"error":2,"errorString":"torrent not registered with this tracker 6UHsVW'*C","eta":262792,"id":25,"leftUntilDone":2275655680,", ...

Change History (3)

comment:1 Changed 11 years ago by charles

  • Keywords needinfo added

I'm not able to reproduce this issue.

I've added a test to libtransmission/json-test.c that attempts to parse the relevant segment you reported. The test passes for me on my two Linux boxes, but I don't know what you're running... could you update to >= r10487 to try out the unit test for yourself?

comment:2 Changed 11 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

Please reopen with more information, if it's still an issue.

comment:3 Changed 11 years ago by charles

  • Version changed from 1.92+ to 1.92
Note: See TracTickets for help on using tickets.