Opened 12 years ago

Closed 12 years ago

#3147 closed Bug (fixed)

qtr delayed to connect to remote session automatically

Reported by: keizie Owned by: Longinus00
Priority: Normal Milestone: 2.01
Component: Qt Client Version: 1.92
Severity: Normal Keywords:
Cc:

Description

On Ubuntu lucid, transmission-daemon is running. qtr connect to daemon.

  1. qtr just shows blank listview initially. But statusbar shows blinking monitors.
  2. After about 3 minutes or less, suddenly listview populated with torrents.
  3. If launched with torrent seed, adding delayed till the 3 minutes pass.
  4. Or can connect manually and immediately with 'Change Session' menu action.

I've traced source code myself but I couldn't tell why it doesn't connect at once while menu action do. They both call TorrentModel::restart() for kickstarting. They can't be different for that matter. I don't understand so I ask for help.

Attachments (3)

settings.json (1.7 KB) - added by yegor 12 years ago.
daemon config
settings.2.json (3.0 KB) - added by yegor 12 years ago.
qtr config
qt_fixAuth.patch (9.0 KB) - added by Longinus00 12 years ago.
make the window title prettier

Download all attachments as: .zip

Change History (22)

comment:1 Changed 12 years ago by charles

I can't reproduce this issue and neither could another tester in #transmission. Is this something that happens every time for you, or occasionally?

comment:2 Changed 12 years ago by keizie

As far as I can tell, it happens always.

comment:3 Changed 12 years ago by charles

Is the server's upload bandwidth saturated with BitTorrent? uploads? If so you may want to cap Transmission's upload speeds to ~85% of your ISP's upload bandwidth.

comment:4 Changed 12 years ago by keizie

No, This line is at 95+ Mbps. And concurrent traffic goes under that limit. Statusbar shows 'Transmission server is responding' at once when mainwin appears.

For more test case, I tried to run qtr via X11 forwarding. I expected delayed auto connection, but session dialog popped up after delay, as localhost is not appropriate. Is there any clue between main() and session dialog procedure?

comment:5 Changed 12 years ago by charles

I'm afraid I still don't understand this ticket. The Qt client seems to be behaving correctly for me. Does this behavior still continue for you in 1.93?

comment:6 Changed 12 years ago by charles

oops, this comment was intended for another ticket

Last edited 12 years ago by charles (previous) (diff)

comment:7 Changed 12 years ago by keizie

Installed 1.93 from ppa:transmissionbt, and found nothing changed. Is there any checkpoint for me to verify?

Changed 12 years ago by yegor

daemon config

Changed 12 years ago by yegor

qtr config

comment:8 Changed 12 years ago by yegor

Confirm the issue on Debian Squeeze (transmission 1.93-2).

rpc-authentication-required must be set to true in daemon in order to reproduce.

Example config files attached. Any comments?

Last edited 12 years ago by yegor (previous) (diff)

comment:9 Changed 12 years ago by keizie

Reproduced. But rpc-authentication-required need to be true for my environment. This is bug in transmission authentication routines, isn't it?

comment:10 Changed 12 years ago by Longinus00

The first http request decides to take forever and I'm not sure why. That blocks everything else and it is quite amusing to watch around 300 requests shoot off after it finally finishes. QHttp is apparently obsolete so I tried ripping it out and replacing it with QNetworkAccessManager which fixed the problem.

comment:11 Changed 12 years ago by Longinus00

Can you guys test my patch to see if solves your problems?

comment:12 Changed 12 years ago by yegor

Thanks for the patch. It fixes the problem. Qtr connects immediately after start now.

comment:13 Changed 12 years ago by Longinus00

My last patch had a bug. I recommend you use my newer patch.

comment:14 Changed 12 years ago by Longinus00

  • Milestone changed from None Set to 2.10
  • Owner changed from charles to Longinus00

comment:15 Changed 12 years ago by charles

Longinus00: several people have reported this behavior in irc in the past. Do you think this patch is low-risk enough for 2.00?

comment:16 Changed 12 years ago by Longinus00

I honestly don't know how risky this is but I don't think it's that risky. Famous last words I know.

Changed 12 years ago by Longinus00

make the window title prettier

comment:17 Changed 12 years ago by keizie

Patch works. Thanks, Longinus00 :-D

comment:18 Changed 12 years ago by charles

  • Milestone changed from 2.10 to 2.01

comment:19 Changed 12 years ago by Longinus00

  • Resolution set to fixed
  • Status changed from new to closed

Fixed by r10769.

Note: See TracTickets for help on using tickets.