Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3153 closed Bug (worksforme)

Transmission crashing on startup

Reported by: Trevreav Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.92
Severity: Normal Keywords:
Cc:

Description

Hi, I'm sorry there are no console bits to add to this. Using Mac running OSX 10.5.8 and Transmission 1.92 (no nightly builds after this). The problem is when I start Transmission. On loading, the Mac has a kernel panic and I get the greyed screen with 'Please restart this computer' in half a dozen different languages. This happens probably about 2/3rds of the way through the Transmission startup window.

thanks trevreav

Change History (12)

comment:1 Changed 11 years ago by livings124

What changes have you made with your preferences? Try deleting your preference file and the Transmission application support folder and see if that resolves it. Also, try a nightly build.

comment:2 Changed 11 years ago by Trevreav

Hi livings124, thanks for the reply. As far as I know I haven't made any changes to any preferences, especially not with Transmission as I haven't been able to get it running since about version 1.6 or so (don't quote me here, I really can't remember). I can't even find any preference file for it, but the application support folder has now gone in the bin. thanks Trevreav

comment:3 Changed 11 years ago by livings124

Config files are listed http://trac.transmissionbt.com/wiki/ConfigFiles. Does removing them resolve your issue?

comment:4 Changed 11 years ago by Trevreav

Well, I might be getting somewhere. I used Appzapper to get rid of everything Transmission related, config files, the lot. Downloaded the latest nightly build and loaded it. It started up fine - I wasn't downloading anything, just left it running in the background while I was using the programmes I've been using all day, and after about 5 mins I got the kernel panic and greyed screen again.

comment:5 Changed 11 years ago by livings124

Sounds like an issue where your network can't handle that many connections. Limit the number of peers in preferences to much lower than it is now, and have very few active torrents at once. You might also benefit from disabling DHT.

comment:6 Changed 11 years ago by Trevreav

Many thanks again for spending the time with me on this. I'll give it a go when I get a moment, have to go out to pick up some work now, but will try tomorrow am. Trevrev

comment:7 Changed 11 years ago by Trevreav

Back to square 1 again I'm afraid. On loading, Transmission brings the whole Mac down. Can't even get to the preferences before it goes. By the way, what's DHT?

Last edited 11 years ago by Trevreav (previous) (diff)

comment:8 Changed 11 years ago by livings124

DHT is the distributed hash table - it's another way to get peers without a tracker. It is enabled in the Peers preference tab. I'm not really sure how to go further. You might get better support on the forums, as I think this is more a localized issue.

comment:9 Changed 11 years ago by Trevreav

Okay, thanks for the help anyway

comment:10 Changed 11 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

comment:11 Changed 11 years ago by Trevreav

I've just had a hunt on the forum and I saw something about running it in 32-bit which I've done and it seems fine now.

comment:12 Changed 11 years ago by livings124

Hmm, very strange.

Note: See TracTickets for help on using tickets.