Opened 11 years ago

Last modified 9 years ago

#3155 reopened Bug

Setting Upload Limit of individual torrrent to 0KB/s stops download

Reported by: TheFlyingWallaby Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.92
Severity: Minor Keywords:
Cc:

Description

If I set the upload limit of an individual torrent to 0KB/s, it stops downloading completely. 1KB/s or above and it returns to full speed download. This behavior persists across all the torrents I've tried. The behavior is not present in 1.90 or 1.82. OS is 10.6.2

Change History (22)

comment:1 Changed 11 years ago by TheFlyingWallaby

  • Summary changed from Setting Upload Limit to 0 of individual torrrent stops download to Setting Upload Limit of individual torrrent to 0KB/s stops download

comment:2 Changed 10 years ago by Lucas

I use the "turtle" setting to make the daemon download throttled when I am at home and speed it up when I am gone. Now I have enountered the problem that if you set the download limit to "0", all downloads completely halt. While I can totally understand this behaviour, there is no way to say "no limit" in the turtle mode. Would be great if it got a little checkbox just like for normal speeds. I think this is related or at least very closed to the original problem, so I commented here instead of opening a new ticket.

comment:3 Changed 10 years ago by livings124

You can't set speed limit mode to unlimited - that's intentional. Set the main limit to unlimited, and then set the speed limit mode to the limited value.

comment:4 Changed 10 years ago by Lucas

I want there to be no download limit in normal mode AND no download limit in turtle but an upload limit of 90 in normal and 40 in turtle mode. I don't see how I can do that with the current system. My current workaround is setting the downloadlimit really high, but I find that unsexy.

Last edited 10 years ago by Lucas (previous) (diff)

comment:5 Changed 10 years ago by livings124

Unfortunately that's outside the scope of the feature. Also, I think that's unrelated to this ticket's issue.

comment:6 Changed 10 years ago by livings124

#3902 is the opposite, where setting download to 0 stops upload.

comment:7 Changed 9 years ago by roeme

  • Resolution set to invalid
  • Status changed from new to closed

If one want's to "abuse the turtle" this way, one could just set the download limit to one's maximum possible download speed. Quite obvious solution IMHO.

comment:8 Changed 9 years ago by x190

roeme: Are you a member of the development team? If not, why are you closing other people's tickets?

comment:9 follow-up: Changed 9 years ago by roeme

x109: I'm not. But since this trac allows me to change the resolution of tickets, I figured I help out with marking old, stale tickets. I assumed there is some moderation/review required by someone of the dev team before the ticket is closed. If I was wrong, sorry for that. (Do you know by chance where I can find the rules for this trac?)

comment:10 in reply to: ↑ 9 Changed 9 years ago by x190

Replying to roeme:

x109[x190]: I'm not. But since this trac allows me to change the resolution of tickets, I figured I help out with marking old, stale tickets. I assumed there is some moderation/review required by someone of the dev team before the ticket is closed. If I was wrong, sorry for that. (Do you know by chance where I can find the rules for this trac?)

Commonsense would suggest that devs should be the only ones to close a ticket regardless of access to editing features. This ticket and its counterpart #3902 are important issues and need to be addressed by someone who knows what the code should be expected to do.

If you want to help, you can post your comments or provide a patch but please do not randomly close tickets.

comment:11 Changed 9 years ago by x190

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:12 follow-up: Changed 9 years ago by livings124

  • Resolution set to invalid
  • Status changed from reopened to closed

x190: As a dev I'm going to disagree with that. In this case it was fine for roeme to close the ticket. I appreciate users closing stale tickets that are no longer relevant.

Last edited 9 years ago by livings124 (previous) (diff)

comment:13 in reply to: ↑ 12 Changed 9 years ago by x190

Replying to livings124:

x190: As a dev I'm going to disagree with that. In this case it was fine for roeme to close the ticket. I appreciate users closing stale tickets that are no longer relevant.

That seems to be a recipe for abuse of the trac ticket system. Just because an unknown poster doesn't agree with the premise of a ticket, he/she is welcome to close it? You chose not to close this ticket and its counterpart #3902, yet it's fine if someone of unknown qualifications does close it? One could close dozens of tickets using that method!

Last edited 9 years ago by x190 (previous) (diff)

comment:14 follow-up: Changed 9 years ago by livings124

We have moderation, so we can reject posts or reopen tickets. I am glad that someone's helping us keep track of old tickets that should've been closed awhile ago.

comment:15 in reply to: ↑ 14 Changed 9 years ago by x190

  • Resolution invalid deleted
  • Status changed from closed to reopened

Replying to livings124:

We have moderation, so we can reject posts or reopen tickets. I am glad that someone's helping us keep track of old tickets that should've been closed awhile ago.

May I ask you why this ticket should be closed? Are you now saying that this is expected behavior, and if so, on what basis? If indeed it is expected behavior then shouldn't this be made clear in the interface, both in turtle prefs, and Inspector->Options? Effectively, setting Upload to 0 KB/s means Download = 0 KB/s. Adjunct to this issue is the fact that Transmission continues to connect to peers even though no data can be exchanged.

That is why I stated in comment:10 that this ticket and #3902 are important issues that go right to the core of how users do/should use turtle mode/Options speed limiting.

comment:16 Changed 9 years ago by roeme

With the first few comments, this ticket drifted away from it's original purpose to an issue with the turtle. Also, the original poster doesn't seem to have any interest, as there are no comments from him whatsoever since. The original bug report, along with the turtle feature issue, are indeed invalid: For the former, as I and others said before, instead of an "unlimited" setting, one could set the limit to one's linespeed. Line speed doesn't change daily, weekly or monthly. For the latter, as it's been stated as well, it is outside of the scope of the feature (additionally to the issues of the former).

May I ask you why this ticket should be closed? Are you now saying that this is expected behavior, and if so, on what basis?

0 is zero, after all. Yes, setting the limit to zero in my opinion means nothing allowed. Blanking the field, or a checkbox beneath (which is available for the global speed limits as of 2.42 - which further invalidates the original bug report!), should instead allow to lift the limit completely.

Again, commonsense would suggest that this ticket should be closed, and, If you, x190, or the original reporter, still have an Issue, create a new, properly and clearly worded feature request (allow "unlimited speeds for speed limit mode") in form of a ticket.

I would've closed this ticket again, but to prevent an unecessary open-close ping-pong "flamewar", I will leave this to a dev now. I already wasted enough time trying to explain why this ticket can be closed and to clarify my actions (which were OK with the devs anyway).

Transmission is awesome, and I will try to help were I can.

comment:17 Changed 9 years ago by cfpp2p

I remember I once set upload speed to zero and then download stopped. It was just a simple idea and stopping download also didn't seem to make sense to me then, nothing complicated. For me this ticket

Setting Upload Limit of individual torrrent to 0KB/s stops download

still seems to correctly and simply describe an inconsistency.

comment:18 Changed 9 years ago by x190

I'll try to be as clear and concise as possible. If the behavior noted in the summary of this ticket and its counterpart #3902 is valid and cannot (or should not) be changed, then setting either up or down to 0 KB/s should automatically re-set its counterpart to 0 KB/s and all connections should be closed.

comment:19 Changed 9 years ago by cfpp2p

well said!, x190

comment:20 Changed 9 years ago by roeme

After a short discussion this ticket must be provided with the following information before further work can be done:

  • Does downloading stop immediately or do they decrease gradually? (when the upload limit is set to 0?)
  • Does the issue still arise with 2.42, or a nightly?

If these information isn't provided in the course of the next few days, this ticket will be considered stale and be closed.

Lucas, x190: For the turtle unlimited speed issue, create a new ticket.

Thank you for your time.

comment:21 Changed 9 years ago by cfpp2p

stops immediately

r13123

comment:22 Changed 9 years ago by redneckmother

I consider the described behaviour to be a bug.

Because my ISP limits downloads between 06:00 and 02:00 EST, I use global settings to avoid throttling during those hours.

However, if a particular torrent is near completion, and will not cause ISP throttling, I wish to modify the torrent to remove adherence to the global settings, and set an upload speed of zero, while leaving the download speed unspecified (and, to my reasoning, unlimited).

Note: See TracTickets for help on using tickets.