Opened 11 years ago

Closed 11 years ago

#3159 closed Enhancement (fixed)

better choosing of which peers to initiate new connections with

Reported by: charles Owned by: charles
Priority: Normal Milestone: 2.00
Component: libtransmission Version: 1.92
Severity: Normal Keywords:
Cc:

Description

Right now the method for picking new peers is somewhat random. It would be better if we took into account which swarms had the best odds for finding non-seed peers.

Change History (3)

comment:1 Changed 11 years ago by charles

Experimental commit in r10500

comment:2 Changed 11 years ago by charles

r10500 introduced a new bug reported by Sharpshot in #3160, which I'm marking as a duplicate of this ticket. That crash is fixed in r10506.

comment:3 Changed 11 years ago by charles

  • Resolution set to fixed
  • Status changed from new to closed

Well it's been a week and there's been no negative feedback in the forums or irc, and the patch seems to be working well. Closing this ticket as fixed.

Note: See TracTickets for help on using tickets.