Opened 8 years ago

Closed 8 years ago

#3184 closed Bug (invalid)

Torrents Being Re-added After Removal

Reported by: WastingBody Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.92
Severity: Normal Keywords:
Cc:

Description

Torrents can be re-added to the webui after restarting the daemon.

Steps:

  1. Download a .torrent file to the watch directory
  2. Let the download complete
  3. Remove the torrent with the webui.
  4. Restart the Transmission daemon

Results: The removed torrent is re-added to the torrent list.

Change History (4)

comment:1 follow-up: Changed 8 years ago by charles

Is the .torrent file still in the watch directory, then?

comment:2 in reply to: ↑ 1 Changed 8 years ago by WastingBody

Replying to charles:

Is the .torrent file still in the watch directory, then?

Yes

comment:3 Changed 8 years ago by charles

That's why it's being re-added then. You should remove it from the watchdir manually or set trash-original-torrent-files to 'true'

comment:4 Changed 8 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

This behavior is by design. You should enable "trash-original-torrent-files"

Note: See TracTickets for help on using tickets.