Opened 8 years ago

Closed 7 years ago

#3191 closed Bug (fixed)

Very long time to quit on MacOSX

Reported by: dtsrppp Owned by:
Priority: Normal Milestone: 2.04
Component: Transmission Version: 1.93
Severity: Normal Keywords:
Cc: mips.tian@…

Description

I have an iMac (intel) and have just upgraded (automatically) to 1.93. It sometimes crashes the computer, sometimes just stops downloading and takes a very long time to quit.

Please help

Change History (40)

comment:1 Changed 8 years ago by livings124

  • Milestone changed from 2.00 to None Set
  • Priority changed from Highest to Normal

Don't set milestones.

comment:2 Changed 8 years ago by livings124

Post crash reports if it's crashing. How long does it take to quit? Sounds like it's a network issue on your end - limit the number of active transfers, number of allowed questions, and bandwidth limits.

comment:3 Changed 8 years ago by Robby

"new mac update worse than what it replaced", that is totally irrelevant to the fixing of the issue. Please choose a proper, descriptive title next time. Thanks in advance!

comment:4 Changed 8 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

There's no real info here.

comment:5 Changed 8 years ago by mipstian

  • Cc mips.tian@… added
  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Summary changed from new mac update worse than what it replaced to Very long time to quit on MacOSX

Let me try to elaborate a bit, as I'm facing the issue, too. When quitting, Transmission *sometimes* takes a very long time to close (a couple of minutes typically, sometimes it's instantaneous, sometimes more). This is unrelated to Transmission activity (happens with 5 or 0 torrents open, no difference). It may be an impression, but I think it takes longer when the application is closed by the system (i.e. when restarting/shutting down mac os x). It's usually faster if I just close it with cmd+q. While it's in this state, Transmission shows "quitting" over the dock icon, and it's totally unresponsive (but I guess that's to be expected). Let me know if I can provide any additional information (developer here, ask for very technical stuff if you need that). I can confirm that this sometimes times out the shutdown/restart process, with MacOSX showing a window indicating just that. Force quit works, and it's instantaneous (yay for unix). Keep up the good work!

comment:6 Changed 8 years ago by Sharpshot

I have this same problem, with one active transfer, multiple times. Doesn't happen all the time though. I'll see if it pops up again, and post some logs.

comment:7 follow-up: Changed 8 years ago by charles

Let me try to elaborate a bit, as I'm facing the issue, too. When quitting, Transmission *sometimes* takes a very long time to close (a couple of minutes typically, sometimes it's instantaneous, sometimes more).

Is this still happening in 1.93 and/or 2.00 beta 1?

comment:8 in reply to: ↑ 7 Changed 8 years ago by mipstian

Replying to charles:

Let me try to elaborate a bit, as I'm facing the issue, too. When quitting, Transmission *sometimes* takes a very long time to close (a couple of minutes typically, sometimes it's instantaneous, sometimes more).

Is this still happening in 1.93 and/or 2.00 beta 1?

I've only ever installed 1.93, so yes. I'll switch to beta right now and let you know if there are any differences.

comment:9 Changed 8 years ago by mipstian

With 2.00b1, so far so good. Closes instantaneously. But my guess is that the problem occurs when Transmission is open for a very long time (I usually leave my MBP, and of course Transmission, on for days). I can't find a way to reproduce the issue: after a reboot, if I try to quit it it'll work (both versions). I noticed that, even when the quitting time is acceptable, 2.00b1 seems to shut down in a blink of an eye, whereas 1.93 took a couple of seconds at least. If I run into this problem again with beta, I'll write here asap. Thanks for the interest and keep up the good work, Transmission is definitely the best bittorrent client for the mac (tried them all :)

Last edited 8 years ago by mipstian (previous) (diff)

comment:10 Changed 8 years ago by livings124

What's the status of this with 2.00b2?

comment:11 Changed 8 years ago by mipstian

I'm on Snow Leopard here, and even after leaving Transmission open for days it shuts down in a second or so. So I'd say it's fixed (for me at least).

comment:12 Changed 8 years ago by livings124

  • Milestone changed from None Set to 2.00
  • Resolution set to fixed
  • Status changed from reopened to closed

I'll mark this as fixed. Please reopen if that's not the case.

comment:13 Changed 7 years ago by mipstian

  • Resolution fixed deleted
  • Status changed from closed to reopened

2.00b2 (10722) issue is still present. left Transmission running for a couple of days, then Restarted my macbook pro. Took so long that the Restart process timed out and asked me to kill it. Being a developer myself, I know these kind of issues are very hard to track down, so please let me know if I can help in any way.

comment:14 Changed 7 years ago by livings124

  • Milestone changed from 2.00 to None Set

How many transfers did you have running? How long did it take to quit (or how long did you wait)? What happens with a nightly build.

comment:15 Changed 7 years ago by mipstian

How many transfers did you have running?

  • None! But, since I opened it, I think I completed about 10 transfers. All completed and "removed" though.

How long did it take to quit (or how long did you wait)?

  • Not sure, I think the timeout is after 30 seconds, or a minute. When the timeout dialog comes out I agreed to kill the application. I'd say at least 30 seconds.

What happens with a nightly build?

  • I don't know! I'll try to install one and get back to you, but it takes a couple of days to reproduce this :(

Edit: installed nightly 10761. I'll try and write here.

Last edited 7 years ago by mipstian (previous) (diff)

comment:16 Changed 7 years ago by livings124

mipstian: ping

comment:17 Changed 7 years ago by mipstian

Didn't happen so far, but I didn't have the chance to leave it running for very long. I'm using 2.00 now.

comment:18 Changed 7 years ago by charles

Ticket #3369 has been closed as a duplicate of this ticket.

comment:19 Changed 7 years ago by charles

  • Keywords Bug unreliable failling removed
  • Severity changed from Critical to Normal

comment:20 Changed 7 years ago by mipstian

2.03, still here (seems a little reduced though)

comment:21 Changed 7 years ago by Robby

Same here with one torrent. I had it running for only a few minutes.

comment:22 Changed 7 years ago by charles

Is this better, worse, or no change with >= r11149?

comment:23 follow-up: Changed 7 years ago by livings124

Is this still an issue with 2.04?

comment:24 in reply to: ↑ 23 Changed 7 years ago by Markus00000

Using 2.04 on 10.6.4. It takes minutes to quit. But at least it always quits.

comment:25 Changed 7 years ago by mipstian

Using 2.04 on 10.6.4. It takes minutes to quit. But at least it always quits.

ditto. Also, I've tried opening Transmission, loading about 40 torrents, "removing" all of them and then close the app. Took about 1 minute to quit.

Last edited 7 years ago by mipstian (previous) (diff)

comment:26 follow-ups: Changed 7 years ago by charles

Is the drive in use while this is going on? I'm wondering if Transmission is flushing data to disk....?

comment:27 in reply to: ↑ 26 Changed 7 years ago by captain

I have witnessed this interminable shut-down problem too, for most versions of Transmission going back a couple of years - currently 2.04 (11151). I thought it might be related to flakey network shares and files being shared with iTunes (which should be more prominently noted as a BAD IDEA ;-), so I moved all files to a dedicated, directly attached, HD just for Transmission. This helped, but hasn't solved this problem.

One thing no one seems to have mentioned is that while Transmission goes into "spinning gay beach-ball of death mode" it's process in Activity Monitor shows it working crazy hard at something extremely memory intensive. Real Memory usage will devour almost ALL available RAM, I saw it eat up nearly 3GB at one point, and Virtual Mem goes to double that number, or more! I can't recall if CPU goes up, but my recollection is that it doesn't seem very CPU intensive, just memory... oh, and this is worst when restarting several hundred paused torrents. Quitting and restarting seems to now be much faster, and sometimes instant, as long as no torrents are paused.

It might help, in the interim, to give a popup message when user tries to mass-pause and/or mass-resume more than a few score torrents. Something along the lines of: "You are attempting to mass-pause/resume a lot of torrents. This may cause Transmission to become unresponsive for a very long time. Are you sure you want to continue with this action?" ;-)

Last edited 7 years ago by captain (previous) (diff)

comment:28 in reply to: ↑ 26 Changed 7 years ago by Markus00000

My drive is definitely not always active when this issue occurs. I cannot remember the long shutdown to happen when I paused my transfers before quitting. In contrast to captain, I usually have less than 10 torrents. 20 at most.

comment:29 follow-ups: Changed 7 years ago by charles

Just to make sure I understand the previous comment: if you pause all the torrents, and then wait a little while before exiting, then there's no delay when exiting?

comment:30 in reply to: ↑ 29 Changed 7 years ago by mipstian

Replying to charles:

Just to make sure I understand the previous comment: if you pause all the torrents, and then wait a little while before exiting, then there's no delay when exiting?

If it helps, I didn't pause them, I cancelled (removed) them, then I waited a couple seconds and then I cmq+q'ed.

comment:31 in reply to: ↑ 29 Changed 7 years ago by Markus00000

Replying to charles:

Just to make sure I understand the previous comment: if you pause all the torrents, and then wait a little while before exiting, then there's no delay when exiting?

Yes, I am quite sure that's the way it is. And I don't even have to wait for long. Pausing is quick since I only have few torrents. Quitting afterwards works almost instantly.

comment:32 follow-ups: Changed 7 years ago by livings124

To clarify, the app does do the equivalent of pausing the transfers when quitting. Is the time to quit without manually pausing consistently and significantly longer than the combined time of pausing the transfers manually, waiting, and quitting?

comment:33 in reply to: ↑ 32 Changed 7 years ago by mipstian

Replying to livings124:

To clarify, the app does do the equivalent of pausing the transfers when quitting. Is the time to quit without manually pausing consistently and significantly longer than the combined time of pausing the transfers manually, waiting, and quitting?

I don't know that but I'm observing the issue even with no torrents at all, so I don't think that's the root cause of this misbehaviour. Also, I got report of the same issue happening under Linux (the latest ubuntu).

comment:34 Changed 7 years ago by livings124

This is with 2.04? How long does it take with no torrents?

comment:35 Changed 7 years ago by mipstian

2.04. Somewhere between 1 second and 2 minutes, regardless of how many torrents are open, even if I launch the app, do nothing and shut it down. If you give me some pointers as to where the shutdown procedure is in the code I think I can debug this myself!

comment:36 in reply to: ↑ 32 Changed 7 years ago by Markus00000

I did some trials from scratch.

1) Without torrents it quits within 1-3 seconds. (Tried many times.)

2) After loading half a GB with 3 torrents, it took maybe half a minute. (Tried once.)

3) After loading only some MB, it quits within 1-3 seconds. (Tried many times.)

This is in tune with my memories since version 1.9.x.

comment:37 Changed 7 years ago by Markus00000

Step 2 is not consistent. After loading some more GB, Transmission quit in 2 seconds.

If it can quit instantly without pausing, I wonder if pausing really makes any difference.

comment:38 Changed 7 years ago by livings124

Markus00000: So it never takes more than half a minute? That is very reasonable, considering it has to notify trackers about torrents being stopped.

comment:39 Changed 7 years ago by Markus00000

Not with my current three torrents. But in the past it definitely took minutes, let's say, 2-4 minutes.

comment:40 Changed 7 years ago by livings124

  • Milestone changed from None Set to 2.04
  • Resolution set to fixed
  • Status changed from reopened to closed

The amount of time it's now taking appears reasonable. It still has to contact trackers and unmap any port mappings.

Note: See TracTickets for help on using tickets.