Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3199 closed Bug (duplicate)

Beachball when starting torrent to AFP mounted drive

Reported by: rptb1 Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.93
Severity: Minor Keywords:
Cc:

Description

Transmission beachballs for long periods when starting transfers to AFP mounted drives.

I have a USB drive attached to my AirPort? Extreme base station, and Transmission is set to download torrents to it. When I add a new torrent, Transmission beachballs, often for several minutes, before starting the transfer. It's hard to tell whether other torrents are still operating during this time.

I think it might be blocking while creating the new empty files to receive the transfer.

If so, I suggest this is done in a thread which won't stop the GUI or other torrents.

I've initially set this to minor severity because it's only inconvenient. Transmission recovers after a while.

Mac OS X 10.6.3, Transmission 1.93

Change History (2)

comment:1 Changed 11 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #1753

comment:2 Changed 11 years ago by rptb1

Heh, "worker disk IO thread to ease the load in the libtransmission/libevent thread". No wonder I couldn't find it. Thanks for linking!

Last edited 11 years ago by rptb1 (previous) (diff)
Note: See TracTickets for help on using tickets.