Opened 11 years ago

Closed 11 years ago

#3201 closed Bug (fixed)

Crash when uploading a torrent file via web ui on a DNS-323

Reported by: Nallep Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.93
Severity: Normal Keywords: 1.93, crash
Cc:

Description

Every time I try to upload this torrent "http://releases.ubuntu.com/10.04/ubuntu-10.04-desktop-i386.iso.torrent" onto the web interface for transmission, transmission crashes. It wont restart until I manually remove that torrent from the torrents and resume directories. This is Transmission 1.93 (10625) running on a DNS-323.

Change History (2)

comment:1 Changed 11 years ago by charles

  • Summary changed from Crash when uploading a torrent file. to Crash when uploading a torrent file via web ui on a DNS-323

I can't reproduce this crash -- the torrent adds successfully for me.

Do you have any debugging information about the crash?

comment:2 Changed 11 years ago by Nallep

  • Resolution set to fixed
  • Status changed from new to closed

I found the problem. when I upgraded to the current transmission, it erased my "download-dir" settings from the settings.json and was trying to save the torrents on / I guess. Updated the settings.json and it's working now. But transmission still shouldn't just segfault and not leave any message of what went wrong, it should atleast leave a log entry that it couldn't write to the specified download-dir. I'll submit an enhancement ticket for that.

Note: See TracTickets for help on using tickets.