Opened 11 years ago

Closed 10 years ago

#3205 closed Bug (invalid)

Crash when adding a torrent on DNS-323

Reported by: Nallep Owned by:
Priority: Lowest Milestone: None Set
Component: Daemon Version: 1.93
Severity: Trivial Keywords: incomplete
Cc:

Description

When the daemon tries to save a torrent to the "download-dir" and it is not a valid dir, or not writable, the daemon just segmentation faults without logging any messages as to why it quit working. Need to at-least log an error message before quitting.

Change History (7)

comment:1 Changed 11 years ago by charles

I'm not able to reproduce this error. When I try adding a torrent to an invalid directory in the daemon, the daemon logs an error message, stops the torrent, and does not crash.

What platform are you running transmission-damon on? Do you have any more information about the crash?

$ ./transmission-daemon -g /tmp/transmission-test/crash -f
[20:11:40.657] Transmission 1.93+ (10637) started (session.c:622)
[20:11:40.657] RPC Server Adding address to whitelist: 127.0.0.1 (rpc-server.c:772)
[20:11:40.657] RPC Server Serving RPC and Web requests on port 9091 (rpc-server.c:945)
[20:11:40.657] RPC Server Whitelist enabled (rpc-server.c:949)
[20:11:40.657] DHT Generating new id (tr-dht.c:378)
[20:11:40.657] Using settings from "/tmp/transmission-test/crash" (daemon.c:447)
[20:11:40.657] Saved "/tmp/transmission-test/crash/settings.json" (bencode.c:1651)
[20:11:40.657] Port Forwarding (NAT-PMP) initnatpmp succeeded (0) (natpmp.c:67)
[20:11:40.657] Port Forwarding (NAT-PMP) sendpublicaddressrequest succeeded (2) (natpmp.c:67)
[20:11:48.658] Port Forwarding State changed from "Not forwarded" to "Starting" (port-forwarding.c:87)
[20:11:48.658] Port Forwarding State changed from "Starting" to "???" (port-forwarding.c:87)
[20:12:03.659] DHT Attempting bootstrap from dht.transmissionbt.com (tr-dht.c:234)
[20:12:47.662] Saved "/tmp/transmission-test/crash/torrents/Brett Koonce - Desktops.e6a56670baae316e.torrent" (bencode.c:1651)
[20:12:53.663] Brett Koonce - Desktops Starting DHT announce (poor, 11 nodes) (tr-dht.c:669)
[20:13:22.666] Couldn't create "/no": Permission denied (utils.c:605)
[20:13:22.666] Couldn't create "/no/such/path/Brett Koonce - Desktops/Content": Permission denied (fdlimit.c:362)
[20:13:22.666] Brett Koonce - Desktops tr_fdFileCheckout failed for "/no/such/path/Brett Koonce - Desktops/Content/sunbeam.png.part": Permission denied (inout.c:134)
[20:13:22.666] Couldn't create "/no": Permission denied (utils.c:605)
[20:13:22.666] Couldn't create "/no/such/path/Brett Koonce - Desktops/Content": Permission denied (fdlimit.c:362)
[20:13:22.666] Brett Koonce - Desktops tr_fdFileCheckout failed for "/no/such/path/Brett Koonce - Desktops/Content/promitory.png.part": Permission denied (inout.c:134)
[20:13:22.666] Brett Koonce - Desktops Pausing (torrent.c:1539)
[20:13:22.666] Saved "/tmp/transmission-test/crash/resume/Brett Koonce - Desktops.e6a56670baae316e.resume" (bencode.c:1651)
[20:13:39.667] Saved "/tmp/transmission-test/crash/stats.json" (bencode.c:1651)

comment:2 Changed 11 years ago by charles

  • Keywords incomplete added; download-dir segmentation fault error logging removed

comment:3 Changed 11 years ago by Nallep

This is the current version of transmission, the uClib and system I'm running it on.

Transmission: Transmission 1.93 (10625)
uClib: libuClibc-0.9.29
System is a DNS-323: Linux DNS-323 2.6.12.6-arm1

No other information is reported by transmission when it crashes, it just segfaults and that's it, nothing written to stdout, stderr

Here's where I got my transmission:
http://forum.dsmg600.info/t2719-%5BREL%5D-Transmission.html

In the settings.json, when download-dir is left as

"download-dir": "",

it segfaults every time I try to add a torrent (or if it has torrents already loaded when it starts up).

comment:4 Changed 11 years ago by charles

Could you ask KyleK to look at this ticket please? I'm consistently unable to repeat this problem, so it's possibly a build issue...

comment:5 Changed 11 years ago by charles

  • Summary changed from No error reporting when trying to write to invalid directory to Crash when adding a torrent on DNS-323
  • Type changed from Enhancement to Bug

comment:6 Changed 10 years ago by charles

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

comment:7 Changed 10 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. Thanks again!

Note: See TracTickets for help on using tickets.