Opened 8 years ago

Last modified 11 months ago

#3215 reopened Enhancement

optionally prefix each download directory with the torrent hash

Reported by: leifj Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.93
Severity: Normal Keywords:
Cc: elliot.wolk@…


If two torrents contain the same filename or directory name transmission gets very confused - data actually gets overwritten which is very bad.

In certain use-cases this is *not* an exception or a bug in the creation of the torrents.

An easy fix would be to introduce a global flag that when set caused transmission to include the torrent hash in the download directory of the torrent. Simply choosing the download directory as suggested in #1496 won't work since that implementation assumes a fixed number of directories to choose from on the transmission server.

Change History (7)

comment:1 Changed 8 years ago by charles

  • Severity changed from Critical to Normal
  • Type changed from Bug to Enhancement

comment:2 Changed 8 years ago by charles

  • Component changed from Daemon to Transmission

#2646 has been marked as a duplicate of this ticket.

comment:3 Changed 7 years ago by charles

#3587 has been marked as a duplicate of this ticket.

comment:4 Changed 5 years ago by jordan

  • Resolution set to invalid
  • Status changed from new to closed

This is moot now that users can rename torrents on their own, so duplicate foldernames can be handled manually, much cleaner than having hashcodes in the filenames in the users' Download directories...

comment:5 Changed 4 years ago by jordan

  • Resolution invalid deleted
  • Status changed from closed to reopened

Bug #5592 points out that renaming torrents is not (by itself) a sufficient fix: user may not realize the overlapping folders' names until it's too late.

comment:6 Changed 4 years ago by teleshoes

  • Cc elliot.wolk@… added

comment:7 Changed 11 months ago by mike.dld

Closed #4129 as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.