Opened 12 years ago

Closed 12 years ago

#3226 closed Enhancement (duplicate)

Better Tracker Error Handling

Reported by: Sharpshot Owned by: charles
Priority: Normal Milestone: None Set
Component: libtransmission Version: 1.93
Severity: Normal Keywords: Tracker Error
Cc:

Description

Currently, tracker errors are removed from the main window if the offending tracker is removed, which works perfectly. This is done by:

1) Clicking the torrent 2) Opening the inspector window 3) Clicking the offending torrent 4) Removing it 5) Then closing the inspector window.

Which are 5 steps that would be nice to automate away from the user.

I see three ways to solve this:

1) Suppress the message away from the main window, and just display it in the inspector. Which would probably be the easiest option. However, tracker errors will only be spotted if the inspector is opened

2) Checking the torrents status, and if it has an error of any kind for more than x seconds/minutes, delete it automatically. I don't like this method, as there are too many scenarios to account for. One scenario that springs to mind is if say a reliable tracker goes down, and you have 20 torrents open, it would remove them from all.

3) Diving a bit deeper and reading what type of tracker error is puts out, then deciding what to do with it.

For example, the most common tracker error I have is: "Requested download is not authorized for use with this tracker."

Which would probably be safe to remove, as it is just a tracker thrown into the .torrent regardless if it’s registered or not.

I think number one is the best option, as it probably has the easiest to implement, still gives the user control, and doesn't bloat the code with something that isn't too important. As having a dead/redundant tracker doesn't seem to have any impact on performance, and the user would open up the inspector if he/she has any problems anyway.

Suggestions/Ideas??

Change History (4)

comment:1 Changed 12 years ago by charles

  • Milestone 2.00 deleted
  • Version changed from 1.93+ to 1.93

Please don't set milestones for a task unless you've got a patch for it and you've already talked it over with the developers. Otherwise, the implication is that you're giving the developers their marching orders.

comment:2 Changed 12 years ago by livings124

  • Milestone set to None Set

comment:3 Changed 12 years ago by Sharpshot

Sure, no problem.

comment:4 Changed 12 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

This appears to be a duplicate of #2930. Closing this in favor of the older ticket.

Note: See TracTickets for help on using tickets.