Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3244 closed Enhancement (fixed)

Transmission-remote doesn't have switch(s) to set torrent bandwidth priorities

Reported by: Astara Owned by: charles
Priority: Normal Milestone: 2.00
Component: Daemon Version: 1.92
Severity: Normal Keywords:
Cc:

Description

Patch below... Ishtar:tools> diff -u transmission-reference-1.92/daemon/remote.c transmission-1.92/daemon/remote.c --- transmission-reference-1.92/daemon/remote.c 2010-05-29 22:38:16.262660699 -0700 +++ transmission-1.92/daemon/remote.c 2010-05-29 22:19:59.670541841 -0700 @@ -82,6 +82,12 @@

{'C', "no-incomplete-dir",

"Don't store incomplete torrents in a different location", "C", 0, NULL},

{'b', "debug", "Print debugging information", "b", 0, NULL},

+ {'B'*256+'h', "bandwidth-priority-high", + "Set torrent Bandwidth Higher than normal","Bh",0,NULL}, + {'B'*256+'n', "bandwidth-priority-normal", + "Set torrent Bandwidth to Normal","Bn",0,NULL}, + {'B'*256+'l', "bandwidth-priority-low", + "Set torrent Bandwidth Lower than normal","Bl",0,NULL},

{'d', "downlimit", "Set the maximum global download speed in KB/s", "d", 1,

"<speed>"},

{'D', "no-downlimit", "Don't limit the global download speed", "D", 0,

@@ -431,6 +437,24 @@

addArg = FALSE; break;

+ case 'B'*256 + 'l': + tr_bencDictAddStr (&top, "method", "torrent-set"); + addIdArg (args, id); + tr_bencDictAddInt (args, "bandwidthPriority",-1); + break; + + case 'B'*256 + 'n': + tr_bencDictAddStr (&top, "method", "torrent-set"); + addIdArg (args, id); + tr_bencDictAddInt (args, "bandwidthPriority",0); + break; + + case 'B'*256 + 'h': + tr_bencDictAddStr (&top, "method", "torrent-set"); + addIdArg (args, id); + tr_bencDictAddInt (args, "bandwidthPriority",1); + break; +

case 'c':

tr_bencDictAddStr (&top, "method", "session-set"); tr_bencDictAddStr (args, TR_PREFS_KEY_INCOMPLETE_DIR, optarg);

Attachments (1)

remote.patch (1.5 KB) - added by Astara 12 years ago.
diff -u output for remote.c patch

Download all attachments as: .zip

Change History (9)

Changed 12 years ago by Astara

diff -u output for remote.c patch

comment:1 Changed 12 years ago by Astara

Added patch as file because wiki formatting and patch didn't agree....

comment:2 Changed 12 years ago by charles

  • Component changed from Transmission to Daemon
  • Milestone changed from None Set to 2.00
  • Owner set to charles
  • Status changed from new to assigned
  • Type changed from Bug to Enhancement

comment:3 Changed 12 years ago by charles

Suggestions for future patches:

  • This patch ignores all the changes that have been made in transmission-remote over the past month or so. Please submit patches made against trunk
  • The man page wasn't synchronized with the code changes.
  • Adding new functionality is not a bug. It should be filed as an enhancement :)

Thanks!

Last edited 12 years ago by charles (previous) (diff)

comment:4 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

Added to trunk for 2.00 by r10702

comment:5 Changed 12 years ago by Astara

How does one check out the trunk. I don't see instructions for doing so in the developer or download sections.

What source control method is used? I assume it's possible to check-out read-only trees and to update them?

regarding manpage --- I take it you added the few lines for this one? (Didn't even think about that...what can I say...a bit narrow focused at times...(often?) -- didn't provide a way to READ current settings either! (Doh! -- though I can read the .resume files, pleasant reading).

regarding enhancement or bug: if no clients have the feature, then it would be an enhancement, but if some clients have the feature but others don't have it yet, that would be a "feature deficiency" or "a bug"...at least that's how I see it.

Or another way of looking at it, does transmission support "feature X". yes/no. If answer is yes, then any individual client not doing so = bug. else = enhancement.

Or do you feel that client inconsistency is a desirable design & implementation state? (It may happen by necessity of how resources are rolled out, but if you agree it isn't desirable, then it's a still a deficiency (bug) and not an enhancement....

(I've had had more than a little QA time in my background...)

:-)

comment:6 Changed 12 years ago by Astara

FWIW...found out answer to 1st Q...(followed breadcrumbs)

svn co svn://svn.transmissionbt.com/Transmission/trunk

comment:7 Changed 12 years ago by charles

The svn co instructions are in the README file... :)

comment:8 Changed 12 years ago by charles

My interpretation is that bugs are things that have been written but don't work properly. If it's a feature that hasn't been added yet, it can't be a bug.

If you're asking for a feature to be added, that's an enhancement request.

However I agree that you could make a decent counterargument. This is probably not something where there is Only One True Answer.

Note: See TracTickets for help on using tickets.