Opened 12 years ago

Closed 12 years ago

#3264 closed Bug (invalid)

output of "-h" in remote should go to stdout, not stderr

Reported by: Astara Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.93
Severity: Normal Keywords:
Cc:

Description

While it is fine for the help text, that is displayed when an error enters an incorrect command, to be displayed to STDERR, it is not desirable or correct to display that output to STDERR when the user uses the '-h' command -- as the help text is correct program output and thus should go to STDOUT.

makes a difference when you try to page the long output: "trm -h |more"....and it doesn't work.

Change History (3)

comment:1 Changed 12 years ago by charles

Which executable are you referring to? transmission-remote -h and transmission-daemon -h should already do write to stdout, not stderr

comment:2 Changed 12 years ago by Astara

I can't reproduce this behavior in the current release. If I run into it again, I'll pay more attention to the problem.

comment:3 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.