Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3268 closed Bug (fixed)

Within each session, each torrent added presents options dialog for that and all previous torrents added in that sesssion

Reported by: Lacrocivious Owned by: Longinus00
Priority: Normal Milestone: 2.01
Component: Qt Client Version: 1.93
Severity: Normal Keywords: add torrent options dialog
Cc:

Description

qtr svn trunk 10728 standalone.

Load FirstOne?.torrent; options dialog appears normally (ok).

Later, load SecondOne?.torrent; options dialog appears for SecondOne?.torrent <2> in front, and when dismissed, FirstOne?.torrent dialog is still underneath (cancel).

Later, load ThirdOne?.torrent; options dialog appears for ThirdOone?.torrent <3> (ok), underneath is SecondOne?.torrent <2> (cancel), FirstOne?.torrent (cancel).

As many torrents as you load -- even the same ones over again -- the options dialog presents incremented-by-one dialog instances.

Stop session, restart Transmission. First torrent loads normally again, second torrent has two options dialogs, third one three, etc.

Already-started, previously-ok'd torrents are not affected by clicking 'cancel' when later, duplicate options dialogs for those torrents are displayed.

Obviously, 'Show options dialog' is checked in preferences.

Disclaimer: In stark contrast to the unspeakable mayhem and slaughter common to all known Transmission releases, no pets or wildlife were harmed by the creation of this ticket.

Attachments (1)

qt_fixFileDialog.patch (3.0 KB) - added by Longinus00 12 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 12 years ago by Longinus00

This might be a bug(feature?) in qt as I am unable to reproduce it. The most obvious workaround is to recreate the file dialog every call.

comment:2 Changed 12 years ago by sterling

I also experience this weirdness with qtr version 1.93 built from source against Qt 4.6.2 on Exherbo Linux. My window manager is KWin running under KDE SC 4.4.4, in case that information is remotely of any use.

Changed 12 years ago by Longinus00

comment:3 Changed 12 years ago by Longinus00

sterling, can you try out my patch?

comment:4 Changed 12 years ago by sterling

Just tested it by loading up 3 .torrent files and it works fine now. No errors apparent in the console. Nice work, thanks!

comment:5 Changed 12 years ago by Lacrocivious

qt_fixFileDialog.patch applied to trunk 2.00+ r10783 appears to fix this problem. Only one options dialog is shown when adding a torrent.

comment:6 Changed 12 years ago by Longinus00

  • Milestone changed from None Set to 2.01
  • Owner changed from charles to Longinus00

Fixed in r10790.

comment:7 Changed 12 years ago by Longinus00

  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 12 years ago by Longinus00

Fixed in 2.0x by r10871.

Note: See TracTickets for help on using tickets.