Opened 12 years ago

Closed 12 years ago

#3272 closed Bug (invalid)

torrent rechecking when >2%complete and daemon restarted

Reported by: veehexx Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 1.93+
Severity: Normal Keywords:
Cc: spach@…

Description

i've been having this issue for a while (since 1.92/1.93 beta & final), and am now using the 2.00beta2 release. this is on a sparc based nas (ReadyNAS DUO).

when i add a torrent and it does not pass ~2% completion and i restart either the transmission daemon or the NAS itself, the torrent will immediately restart where it left off. however, once it goes over ~2% downloaded, and a restart occurs, then transmission will recheck the file. this happens on every restart of the daemon until the torrent reaches seeding status.

i've checked various things:

  • timestamp of the resume data [this is being touched when the transmission daemon stops]
  • different torrents & trackers [no difference]
  • filenames [nothing specific appears to be causing it; this bug affects all torrents]
  • filesize [happens on all sizes; MB's or GB's - smallest test was 600mb ubuntu image]
  • torrent quantity [this happens with either 1 or 20+ torrents loaded, either active or paused]

Change History (7)

comment:1 Changed 12 years ago by spach

  • Cc spach@… added

i have the same problem (or a very similar one, as mine never gets to 2%, just hangs immediately). environment is OS X, latest version, all patches, with a ReadyNAS NV+, latest firmware with a volume mounted using AFP. similar to the OP i've had the issue starting somewhere around 1.92 or so.

when i add a torrent file, transmission hangs with the spinning beachball of death. i need to kill and restart it, at which point it then checks the existing data (though there is really none to check, it still takes quite some time). once this is complete, it proceeds as normal until complete.

i can verify that if i change the save location for the downloaded file to a directory on the local drive this isn't an issue, so i'm guessing it's something to do with saving to a networked volume, or the readynas specifically.

comment:2 Changed 12 years ago by veehexx

i just want to clarify that im running transmission on the NAS itself, and not on another machine. thus im using daemon+webgui, and not a specific client. also, i've only recently purchased my NAS and i started using transmission around 1.92, rather than the issue started at 1.92 :)

comment:3 Changed 12 years ago by veehexx

upgraded to 2.00 final, and still the same issues (although checking speed has notably improved :))

comment:4 Changed 12 years ago by charles

How do you shut the daemon down?

For example, if you try stopping the torrent and waiting a second before killing the daemon, does the torrent still get rechecked the next time you start Transmission?

comment:5 Changed 12 years ago by spach

hmm... ok, if you're using the daemon our issues do appear to be different, although possibly related (i get suspicious when we're both writing to the same breed of NAS). i can echo the comments about 2.0 final having the same issues, and the improved checking speed.

in my case, when i start (not just add) a new torrent, the display begins with "downloading from X of N peers". N increments a bit, but it appears that as soon as X goes to 1 it hangs. i assume this is when it opens the file for writing. as mentioned before, when i kill and restart the program, it goes through the checking sequence and when completed starts the torrent as normal and goes about its merry way.

i don't know if i should open this as a separate issue or wait to see if there's a resolution that ends up being specific to the ReadyNAS that might fix my issue...

comment:6 Changed 12 years ago by veehexx

im not sure how the daemon starts/stops. i have alerts Super-Poussin (developer of the readynas transmission addon), and we are working towards a fix. he's moddified the shutdown process to login to to webgui, pause all torrents, and then end the daemon.

when the daemon is restarted, torrents are in a paused status, but when manually resumed, they dont recheck! it obviously needs a touch more work so torrents start in their last status, but it's stopped the constant rechecks.

i think this bug report can be closed since it seems pretty obvious the issue is not with transmission, but with how readynas/addon works. thanks for your time and sugestion, charles.

for reference if others are watching this: http://www.readynas.com/forum/viewtopic.php?p=240158#p240158, fix in 2.01b5 for the sparc platform. no release yet for x86.

comment:7 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

closing this ticket based on veehexx's suggestion in his previous comment.

Note: See TracTickets for help on using tickets.