Opened 12 years ago

Closed 12 years ago

#3279 closed Bug (duplicate)

no feedback(status) given to remote clients if daemon fails an operation

Reported by: Astara Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 1.93
Severity: Normal Keywords:
Cc:

Description

Had a permissions problem. Was trying to move a completed torrent from a download area to a completed area. I used the "--move" command on transmission-remote. It gave back status of 'ok', but nothing happened. Turns out the target directory, owned by the 'torrent daemon', was missing a write permission.

A second example was with the 3rd party, Windows "Transmission Remote GUI" program. When you add a torrent, it asks for the final directory to place the download in. I had also specified for the torrent to be moved when done in that interface. It also failed with no feedback.

Some way for the daemon to communicate status (or failure) back to a remote needs to be provided.

Perhaps on something like '--move' it would be easiest just to wait, but if it is a large torrent that involves a copy -- and worse, to or from a slow device, that wait could take a while.

Another possibility would to keep a log of transactions with date+time source(ip) command, params and status. That could allow retrieval of status later on? In cases where it could be a long command would probably enter at least 2 log entries -- start and complete. Multiple log entries could be added if there were multiple warnings -- but this would allow some communication of status back to a remote client if something "went wrong".

Another way of handling this particular situation (ignoring the larger issue of sending feedback to the client) would have been if there was some type of "force" option in effect at the daemon or at the client. If "force" is in effect (like the "-f" flag to "rm" or "mv") then if the daemon owns the target, it could adjust the permissions necessary to achieve it's goal and set them back when done, but this wouldn't address the issue of what happens when it "can't" do what is requested.

Change History (1)

comment:1 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This ticket is a duplicate of #2870

Note: See TracTickets for help on using tickets.