Opened 12 years ago

Closed 12 years ago

#3308 closed Bug (fixed)

Don't stop/restart torrents when setting the local data's location

Reported by: charles Owned by: charles
Priority: Normal Milestone: 2.01
Component: libtransmission Version: 2.00
Severity: Normal Keywords: backport-1.9x
Cc: howl.nsp@…

Description (last modified by charles)

  1. Stopping and restarting causes us to lose our peers, which isn't always a good idea if we were already uploading to peers before becoming complete
  1. There's minor bandwidth waste of unnecessary extra announces
  1. Since incomplete-dir torrents are moved when completed, Transmission sends a quick series of completed/stop/start announces. xbtt reportedly has trouble with rapid-fire announces like this, so Transmission 1.9x and 2.00 might confuse xbtt trackers. This sounds like xbtt's bug to me, but nevertheless this isn't behavior that other clients exhibit. Also, it's easier to fix this, and to deploy the fix, on the Transmission side.

Change History (14)

comment:1 Changed 12 years ago by charles

  • Description modified (diff)

comment:2 Changed 12 years ago by howl

Yes, issue number 3 is only tracker bug, the tracker where I'm staffer don't have that issue, anyway 1 and 2 are seems to be good reasons for this.

comment:3 Changed 12 years ago by charles

  • Keywords backport-1.9x added

comment:4 Changed 12 years ago by charles

  • Status changed from new to assigned

fixed in trunk by r10839

comment:5 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in the 2.0x branch by r10862

comment:6 Changed 12 years ago by howl

  • Cc howl.nsp@… added
  • Resolution fixed deleted
  • Status changed from closed to reopened

I have tested this one with 2.01 having Incomplete torrents in Incomplete folder and when completed move them to another drive. The reports where:

hace 7 min. started (Martes 29 Junio 2010, 00:29)

hace 0 min. completed (Martes 29 Junio 2010, 00:36)

hace 0 min. stopped (Martes 29 Junio 2010, 00:36)

hace 0 min. started (Martes 29 Junio 2010, 00:36)

So when moving the file was between stop and start events, also moving the file when setting the local data's location when the file is completed to another place stop and start are send.

Using Transmission 2.01 (10898).

Last edited 12 years ago by howl (previous) (diff)

comment:7 Changed 12 years ago by howl

Moving completed to another place in the same drive doesn't stop start.

comment:8 Changed 12 years ago by howl

I can concrete this more, really is not moving to another drive, is with all moves that implies a copy of the file when stop start is performed, when the move consist in reallocating the same file stop start is not performed. For example moving to the same drive but different partitions also makes stop start.

comment:9 Changed 12 years ago by charles

I can't understand what you're saying. :(

comment:10 Changed 12 years ago by lucke

Howl seems to be saying that whenever the data is actually copied and deleted - which happens when you move it between filesystems - the torrent gets stopped and started; which seems to be a pretty logical behaviour to me.

comment:11 Changed 12 years ago by howl

Yes, that's what I said, anyway I reopened because I thought this ticket was intended for all the move situations, if not close it immediately, moving between file systems change the logical location of files so perhaps can't be done without stop start.

comment:12 Changed 12 years ago by livings124

  • Resolution set to fixed
  • Status changed from reopened to closed

This seems to be logical behavior. Please reopen if that's not the case.

comment:13 Changed 12 years ago by howl

  • Resolution fixed deleted
  • Status changed from closed to reopened

There is a way to do this avoiding stop start events. Manually copy the file to the new desired location in a another file-system. In Transmission right click the torrent and define the new location where you copy the file and set the combo to data is already there. Delete the original file. Transmission wont stop start and will continue seeding without losing peers and the file has been moved to a different file-system.

I reopen it because seems possible to do that, anyway if it's not the same situation as I think, reclose it and sorry.

comment:14 Changed 12 years ago by livings124

  • Resolution set to fixed
  • Status changed from reopened to closed

Users are free to do that, but application-wise that doesn't really apply.

Note: See TracTickets for help on using tickets.