Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#3324 closed Bug (fixed)

"transmission-remote --add" has no output/status-message

Reported by: Xake Owned by: charles
Priority: Normal Milestone: 2.11
Component: Daemon Version: 2.10
Severity: Minor Keywords: regression
Cc:

Description

Since upgrading my desktop to 2.00, transmission-remote (which I use to add torrents to another machine running 1.93) does not output any information. Before if there was no new torrents you got a message about trying to add broken torrent, or you got a success/duplicate torrent/whatever message. Now I got this: (for three torrents in Desktop) xake@lillen ~ $ transmission-remote liten -a Desktop/*.torrent xake@lillen ~ $

This is the standard way for me to add a bunch of torrents, and I have also seen all torrents sometimes not being added. So please either add these back, or add an --verbose option.

Change History (8)

comment:1 Changed 12 years ago by charles

  • Milestone changed from None Set to 2.01
  • Owner set to charles
  • Severity changed from Normal to Minor
  • Status changed from new to assigned

comment:2 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in trunk by r10849

fixed in the 2.0x branch by r10850

comment:3 Changed 11 years ago by thuerrsch

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 2.00 to 2.10

This seems to be a regression in Transmission 2.10. After updating from 2.04, I'm once again getting no textual output from transmission-remote when submitting a torrent to my server, no matter if it's added successfully or not.

transmission-remote 2.10 (11294) on Ubuntu Maverick.

(I hope I'm not overstepping any boundaries by simply re-opening this bug. If so, please give me an angry frown and tell me what to do instead.)

comment:4 Changed 11 years ago by Xake

Can confirm since upgrade to 2.10:

xake@lillen ~ $ for t in Downloads/*.torrent ; do transmission-remote liten.dodi -a "$t" ; done xake@lillen ~ $

This was for one torrent, it should tell me if it succeded, the torrent was missing/corrupt or if it was a dupe. But here nothing.

comment:5 Changed 11 years ago by charles

  • Keywords regression added
  • Milestone changed from 2.01 to 2.11

comment:6 Changed 11 years ago by charles

  • Resolution set to fixed
  • Status changed from reopened to closed
  • Summary changed from transmission-remote has no output/status-message to "transmission-remote --add" has no output/status-message

confirmed. This regression was introduced in r11048.

Fixed in trunk for 2.11 by r11318

comment:7 Changed 11 years ago by Xake

Thank you for quick actions.:-)

comment:8 Changed 11 years ago by thuerrsch

Confirmed fixed in 2.11. Thanks a lot for the incredibly quick fix!

Note: See TracTickets for help on using tickets.