Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3330 closed Bug (invalid)

2.00+ (10810) Checking message log causing hang.

Reported by: r0n1n Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 2.00+
Severity: Normal Keywords:
Cc:

Description

If I run transmission for more than an hour then check the message log will cause transmission hang causing me to force quit. Here is the hangreporter log. http://transmission.pastebin.com/XBmGVNWG

Change History (6)

comment:1 Changed 12 years ago by r0n1n

I think the cause of this hang is when the message log gets overloaded with cache messages, every second there is message related to removing blocks from the cache.

comment:2 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

Those are debugging messages to help ensure the new cache code is stable. If they're bothering you turn off debugging for now... but I'm going to leave those log messages in the nightlies for the next few days. :)

comment:3 Changed 12 years ago by r0n1n

OK, I'll turn off debugging until the new cache code is stable. Thanks. :)

comment:4 Changed 12 years ago by charles

The tr_ndbg() call has been removed in r11008

comment:5 Changed 12 years ago by Ryoujin

The slowdown is back with r11014.

comment:6 Changed 12 years ago by Ryoujin

Seems fixed with r11015.

Note: See TracTickets for help on using tickets.