Opened 11 years ago

Closed 11 years ago

#3339 closed Bug (fixed)

crash when download some magnet urls

Reported by: javatmn Owned by: charles
Priority: Normal Milestone: 2.01
Component: libtransmission Version: 2.00
Severity: Major Keywords: backport-1.9x crash magnet
Cc:

Description

i run a daemon transmission on an ARM box, i access by its web-client. When i try to download this magnet url, it always crashes after it retrieved torrent meta-data and just start to download the files. If i close the web-client page(i uses firefox browser), then transmission daemon does not crash but it can not download any bytes, once i connect via web-client again, it crashes immediated. The url is pasted here:


magnet:?xt=urn:btih:KVLOGHM7FWPRHBCQCJMY2PIWWMNZRI4Q&tr.0=http://idowns.org:6969/announce&tr.1=http://idowns.org:2710/announce&tr.2=http://tracker.bittorrent.am:80/announce&tr.3=http://tracker.openbittorrent.com/announce&tr.4=http://tracker.openbittorrent.com:80/announce&tr.5=http://denis.stalker.h3q.com:6969/announce&tr.6=http://torrent-download.to:5869/announce&tr.7=http://tracker.publicbt.com:80/announce&tr.8=http://tracker.prq.to/announce


I once try do track the crash with strace, it indicates that SIGFPE is the cause. I can do no more debug as my embedded arm box only have 64M RAM.

--- [root@tina ~]# uname -a Linux tina 2.6.29.4-FriendlyARM #2 Thu Jun 18 23:37:50 CST 2009 armv4tl unknown [root@tina ~]# cat /proc/cpuinfo Processor : ARM920T rev 0 (v4l) BogoMIPS : 201.93 Features : swp half CPU implementer : 0x41 CPU architecture: 4T CPU variant : 0x1 CPU part : 0x920 CPU revision : 0

Hardware : FriendlyARM Mini2440 development board Revision : 0000 Serial : 0000000000000000 [root@tina ~]#


Change History (2)

comment:1 Changed 11 years ago by charles

  • Component changed from Transmission to libtransmission
  • Owner set to charles
  • Priority changed from High to Normal
  • Status changed from new to assigned

comment:2 Changed 11 years ago by charles

  • Keywords backport-1.9x added
  • Milestone changed from None Set to 2.01
  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in trunk by r10842

fixed in 2.0x branch by r10843

Note: See TracTickets for help on using tickets.