Opened 12 years ago

Closed 12 years ago

#3359 closed Bug (duplicate)

Duplicate trackers

Reported by: Renara Owned by:
Priority: Lowest Milestone: None Set
Component: Transmission Version: 2.00
Severity: Trivial Keywords:
Cc:

Description

I only recently discovered the ability to paste uTorrent compatible tracker lists (new line separated) into a torrent's inspector window, but I'm loving it as as some torrent files don't always seem to have all the trackers listed that they should.

Anyway, a minor bug it seems is that Transmission doesn't check when adding trackers that the tracker is not already in the torrent's tracker list, meaning you can end up with a torrent having the same tracker listed multiple times.

I'm not sure that this has any negative effects, but on the off chance it produces duplicate tracker requests, and for neatness sake, I thought I'd report it =)

Attachments (1)

TrackerList.txt (1.1 KB) - added by Renara 12 years ago.
List of trackers with identical entries

Download all attachments as: .zip

Change History (4)

comment:1 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

Closing this ticket as a duplicate of #2495.

comment:2 Changed 12 years ago by Renara

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Hmm, I'm not 100% sure that this is the exact same issue? I had this happened to me earlier today (which is why I posted), and a number of the trackers added are identical to the ones already listed, and they were added anyway. Is the behaviour different when pasting multiple items at all?

I appreciate that more exhaustive checks are harder, but really all that's needed is for URLs being added to always insert a port number (if one isn't present), as well as /announce, and so-on, i.e - ensure the URLs are as properly formed as possible when stored internally, that why similar URLs are much easier to compare.

But ehm yeah; I'm not sure that in this case the URLs are only similar, as far as I can tell they're identical and yet still being added. I'm going to add the tracker list for the recent case; now, there are a few instances of :80 being ignored (which I do think is a case that should be checked for since it's quite common), but the one to notice is the URL: http://inferno.demonoid.com:3393/announce appearing twice consecutively (it must have been the first in the list I pasted, and last one already in the list at the time).

Changed 12 years ago by Renara

List of trackers with identical entries

comment:3 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from reopened to closed

I think it's a mistake to nanny the user in cases like this.

As a lesser concern, the amount of code it'll take to do this in Mac + GTK + Qt + Web is not worth it.

Note: See TracTickets for help on using tickets.