Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#3374 closed Enhancement (wontfix)

Option for IPv6-only peer traffic

Reported by: FliesLikeABrick Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.01
Severity: Normal Keywords:
Cc: berni@…

Description

This is a wishlist-type item. I would like for there to be an option to only use IPv6 to talk to peers (and a separate option for IPv6-only tracker traffic). This would help in situations where users only want to seed to v6 users (for whatever reason, be it practical or of a more religious/proactive sort).

Change History (5)

comment:1 Changed 12 years ago by jch

Hmm... isn't that easily done with a few firewall rules?

--jch

comment:2 Changed 12 years ago by livings124

  • Resolution set to wontfix
  • Status changed from new to closed

This seems like something that should be done at the network level, not the app level.

comment:3 Changed 12 years ago by jch

To the original reporter: please feel free to reopen if you have a clear idea of what should happen at the Transmission level that cannot be easily done at lower layers.

--jch

comment:4 Changed 12 years ago by berni

  • Cc berni@… added

I have the same "requirement". You can easily block incoming connections with the firewall, but you cannot block outgoing connections that easily.

The easiest way is to use a blocklist that covers all of IPv4

IPv4:0.0.0.0-255.255.255.255

that blocks all in- and outbound connections from IPv4. But the tracker part is still IPv4-only (see bug #1731) and cannot be fixed that easily as far as I can see. In older versions one could just change the IPRESOLVE option of libcurl back to ANY and it worked, but newer versions do way too much around it.

comment:5 Changed 10 years ago by Harry

I know this is an old ticket, but a better "solution" for anyone Googling this is to set bind-address-ipv4 and bind-address-ipv6 in your config file. Make bind-address-ipv4 be 127.0.0.1, and bind-address-ipv6 be whatever your IPv6 address is. You'll probably want to delete your dht.dat too, so you bootstrap to new IPv6-only peers.

Using the blocklist like that will flood your logs with denied peers and DHT won't really work properly. Binding to localhost has its own problems (such as IPv4 tracker resolving won't work), but these are much smaller problems than those caused by the blocklist.

Note: See TracTickets for help on using tickets.