Opened 6 years ago

Closed 6 years ago

#3388 closed Bug (fixed)

file completion percentage no longer updates

Reported by: leena Owned by: charles
Priority: Normal Milestone:
Component: libtransmission Version: 2.04+
Severity: Normal Keywords:
Cc:

Description

The files inspector tab in the mac client always lists 0.00% completion for all files.

using latest svn build (r10930)

Change History (15)

comment:1 Changed 6 years ago by livings124

  • Version changed from 2.01 to 2.01+

comment:2 Changed 6 years ago by charles

  • Milestone None Set deleted
  • Owner changed from livings124 to charles
  • Status changed from new to assigned

comment:3 Changed 6 years ago by charles

  • Component changed from Mac Client to libtransmission

I think this is fixed by r10935. Please reopen this ticket if this problem continues for you.

comment:4 Changed 6 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:5 Changed 6 years ago by livings124

This is fixed with r10950

comment:6 Changed 6 years ago by leena

  • Resolution fixed deleted
  • Status changed from closed to reopened

Doesn't work in mac client, r10986. Only seeing completions of 0.00% or 100.00%, nothing in between.

comment:7 Changed 6 years ago by charles

  • Component changed from libtransmission to Mac Client

Not seeing this in the GTK+ client... bumping back to Mac so livings can give it a look

comment:8 Changed 6 years ago by livings124

  • Component changed from Mac Client to libtransmission

This looks to be an issue with tr_file_stat's progress only returning 0.0 or 1.0.

comment:9 Changed 6 years ago by charles

  • Status changed from reopened to new

confirmed. Thanks livings

comment:10 Changed 6 years ago by charles

I think this is fixed now in r10990.

Can one of you confirm the fix works in the mac client? If so, feel free to close this ticket.

comment:11 Changed 6 years ago by Rolcol

r10990 worked for me.

comment:12 Changed 6 years ago by livings124

  • Resolution set to fixed
  • Status changed from new to closed

Works for me too.

comment:13 Changed 6 years ago by charles

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:14 Changed 6 years ago by charles

  • Status changed from reopened to new

comment:15 Changed 6 years ago by charles

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.