Opened 11 years ago

Closed 11 years ago

#3397 closed Bug (fixed)

checksum errors when downloading files whose names are encoded in iso-8859-1

Reported by: dmig Owned by: charles
Priority: Normal Milestone: 2.02
Component: libtransmission Version: 2.01
Severity: Normal Keywords: checksum, download
Cc:

Description

Transmission fails to download torrent (see attachments), continiously reporting checksum errors of 21 piece.

Reproduced on: transmission-daemon 2.0, 2.01 mipsel build, transmission-gtk 1.93 x86 build.

uTorrent successfully finished torrent download after transmission fails, so looks like, this is transmission bug.

Attachments (1)

failed.log (1.5 KB) - added by dmig 11 years ago.
transmission-daemon log excerpt, showing which pieces failed and how often

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by dmig

transmission-daemon log excerpt, showing which pieces failed and how often

comment:1 Changed 11 years ago by dmig

If needed, I may attach part of full transmission-daemon log.

comment:2 Changed 11 years ago by dmig

Problem is likely caused by file names containing russian characters.

comment:3 Changed 11 years ago by charles

I haven't had a chance to look at the .torrent yet, but is there any way you can repeat this bug on a torrent that's *not* 12 GB large?? :)

comment:4 Changed 11 years ago by dmig

Actually, you can download only failing pieces of torrent. Each is 16mb. Or, I can look, which files are in these pieces

comment:5 Changed 11 years ago by charles

  • Component changed from Transmission to libtransmission
  • Milestone changed from None Set to 2.02
  • Owner set to charles
  • Status changed from new to assigned
  • Summary changed from Transmission fails to download torrent due to checksum errors to checksum errors due to filename collisions
  • Version changed from 2.01+ to 2.01

The problem is that the filenames in the .torrent file are not all encoded in UTF-8. In this torrent's case, it appears to be using ISO-8859-15. This is the .torrent creator's problem -- the BitTorrent? spec requires UTF-8 encoding.

However, we can try to convert from ISO-8859-15 to UTF-8 ...

comment:6 Changed 11 years ago by charles

  • Summary changed from checksum errors due to filename collisions to checksum errors when downloading files whose names are encoded in iso-8859-1

comment:7 Changed 11 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in trunk by r10963

fixed in the 2.0x branch by r10964

Note: See TracTickets for help on using tickets.