Opened 12 years ago

Closed 11 years ago

#3450 closed Bug (fixed)

Regression: D-Bus support broken.

Reported by: rb07 Owned by: charles
Priority: Normal Milestone: 2.10
Component: Qt Client Version: 2.03
Severity: Normal Keywords: DBUS D-Bus Qt
Cc:

Description

Changeset 10717 for trunk/qt/dbus-adaptor.h and dbus-adaptor.cc added a parameter to AddMetainfo(), that breaks the operation since the method is sent only one parameter, not two, in app.cc:386.

You could either overload AddMetaInfo() and later finish what seems like a partial change, or send an empty string always as second parameter (if that makes sense, since the parameters are now named "payload" and "filename").

Reverting the change makes Transmission-Qt work (handling file and magnet association). It could be enhanced with a message panel for the case of a non-existent file name...

Attachments (1)

dbus-adaptor.diff (828 bytes) - added by rb07 12 years ago.
Patch I used on QTransmission for Windows.

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by rb07

Patch I used on QTransmission for Windows.

comment:1 Changed 11 years ago by charles

  • Milestone changed from None Set to 2.10
  • Status changed from new to assigned

The patch is fine, but thinking over the code I think the extra parameter was a mistake... it was added mostly to allow the server to handle the "delete source file" feature when adding a torrent, but that doesn't handle the case when the server is on another machine and doesn't share the filesystem.

Thinking it over, IMO the original caller needs to be the one to handle that responsibility, not the server.

comment:2 Changed 11 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in trunk by r11087

Note: See TracTickets for help on using tickets.