Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3467 closed Bug (fixed)

Wrong redirect

Reported by: Platinum Owned by: charles
Priority: Normal Milestone: 2.04
Component: Web Client Version: 2.03
Severity: Normal Keywords: http redirect
Cc:

Description

When I try to access the web interface I get redirected to a wrong address. It only seems to happen the first time each session, then when I re-enter the URL it goes to the right address.

trying to connect to:
http://<my NAS IP>:9091/transmission/web/
got redirected to:
http://<my NAS IP>:9091/transmission/transmission/web/

I am also using a proxy to use the web interface on port 80, but using the proxy always redirects to the wrong address so I can't access the web interface at all. Might be related to ticket #3411, this started when I updated from 2.00 to 2.03.

Change History (11)

comment:1 Changed 11 years ago by charles

#3411 is what I'm thinking, too.

To test that theory -- do you build your own copy of Transmission? If you revert r10984, does the problem go away?

comment:2 Changed 11 years ago by Platinum

Yes reverting r10984 fixed it.

comment:3 Changed 11 years ago by charles

Hmm. I don't see what r10984 could be doing wrong... the new code looks straightforward enough. The leading '/' in the redirect should resolve to an absolute path, right?

I'm not able to reproduce this error, either. Hmm, what to try...

What browser are you using? If you try a different browser does the problem persist?

comment:4 Changed 11 years ago by Platinum

I think I have found the problem.

Line 611 libtransmission/rpc-server.c from transmission-2.03.tar.bz2:

const char * location = "transmission/web/

It is missing the leading '/'.

comment:5 Changed 11 years ago by charles

Ah, well spotted! :)

Does prepending a / there fix the issue on your system?

comment:6 Changed 11 years ago by Platinum

Yes it does.

comment:7 Changed 11 years ago by charles

  • Keywords backport-2.0x added
  • Milestone changed from None Set to 2.10
  • Owner changed from kjg to charles
  • Status changed from new to assigned

Looks like the patch made to the 2.0x branch (r10985) was wrong. r10984 was made to trunk, and that one seems to be working.

Marking this for 2.10, since it's not likely that we'll have a 2.04 release. However I'll add the backport-2.0x tag in case we do.

comment:8 Changed 11 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:9 Changed 11 years ago by charles

  • Milestone changed from 2.10 to 2.04

Well, what a difference a day makes. Apparently we're doing 2.04 after all :)

comment:10 Changed 11 years ago by charles

Fixed in the 2.0x branch by r11111

comment:11 Changed 11 years ago by charles

  • Keywords backport-2.0x removed
Note: See TracTickets for help on using tickets.