Opened 10 years ago

Closed 8 years ago

#3473 closed Enhancement (duplicate)

Show folder of torrents in inspector

Reported by: dark465 Owned by: marktraceur
Priority: Normal Milestone: None Set
Component: Web Client Version: 2.13
Severity: Normal Keywords: torrent, folder, inspector
Cc:

Description

If a torrent contains multiple folders it would be nice to see the folders in the inspector instead of all files listed. Also the possibility to mark complete folders for download should be included.

Change History (9)

comment:1 Changed 10 years ago by charles

  • Component changed from Transmission to Web Client
  • Owner set to kjg
  • Priority changed from High to Normal

comment:2 in reply to: ↑ description Changed 10 years ago by dark465

  • Version changed from 2.03 to 2.13

Replying to dark465:

If a torrent contains multiple folders it would be nice to see the folders in the inspector instead of all files listed. Also the possibility to mark complete folders for download should be included.

Is this already somewhere in process? This would be a very useful feature!

comment:3 Changed 10 years ago by jordan

This probably isn't going to get implemented unless someone submits a patch for it.

The web client currently has no primary maintainer, and is getting by on submitted patches.

comment:4 Changed 10 years ago by marktraceur

  • Owner changed from kjg to marktraceur
  • Status changed from new to assigned

I'll see what I can throw together. This looks like a cool thing to start with on this project! If there are any specific things you want implemented, feel free to add them here.

comment:5 Changed 10 years ago by marktraceur

I took a look at the code last night, and it really doesn't seem to have any infrastructure for doing this. I think it might take a rewrite of the TorrentFile? class in torrent.js for this to work, which is something I don't want to do as an outside contributor. If someone more familiar with the web side could look at it, that might be better.

comment:6 follow-up: Changed 9 years ago by requinix

  • Version changed from 2.13 to 2.42

It's by no means fancy, and I wouldn't submit it as a patch, but for myself I made a small edit to file-row.js to show the directories bulleted like

  • Top level
  • /Second level
  • /File.ext

file-row.js:138 from v2.42 - inside the FileRow?.createRow function:

  name = file.name || 'Unknown';
+ name = "&bull; " + name.replace(/\//g, "<br/>&bull; /");
- name = name.substring(name.lastIndexOf('/')+1);
  name = name.replace(/([\/_\.])/g, "$1&#8203;");

(name contains the path relative to the download directory)

Without looking too hard it seems to build the list one file at a time; I can imagine keeping an object/hash of dirnames and nested ULs...

comment:7 Changed 9 years ago by livings124

  • Version changed from 2.42 to 2.13

comment:8 in reply to: ↑ 6 Changed 9 years ago by killemov

Replying to requinix:

Without looking too hard it seems to build the list one file at a time; I can imagine keeping an object/hash of dirnames and nested ULs...

Actually the main challenge is that the files in a torrent are in no specific order. So presenting the files in proper tree-view order is actually not that simple. Presenting the files in torrent order with tree-view like paths gets very confusing with many files or much nesting. I know, because I have implemented both in Shift. https://forum.transmissionbt.com/viewtopic.php?f=8&t=12555

comment:9 Changed 8 years ago by jordan

  • Resolution set to duplicate
  • Status changed from assigned to closed

This was fixed in 2.70 as #5013.

If we want to be pedantic, #5013 is the duplicate of this ticket... however since #5013 is the one that got marked as fixed for 2.70, I'm marking this as the duplicate of that :)

Note: See TracTickets for help on using tickets.