Opened 11 years ago

Closed 11 years ago

#3484 closed Bug (duplicate)

Kernel Panics

Reported by: zarkon55 Owned by:
Priority: Highest Milestone: None Set
Component: Transmission Version: 2.03
Severity: Major Keywords:
Cc:

Description

I have seen KPs on two completely separate hardware platforms:

On a newer Mac Mini, and also on a brand new MacBookPro?.

Attached is a sample KP dump.

It happens less using the older 1.8 version of SW, but does still occur @ that level of software. The latest version 2.03 KPs almost ever time on the MBP, and less frequently on the Mini.

I've downloaded the source, and when running in Xcode debug mode, it does not seem to happen. (At least I have not seen it happen in debug mode)

The "Run with performance tool - Leaks" in Xcode shows a ton of memory being allocated and never referenced again, so this might be part of the problem.

Seems to happen more on larger files (around 1Gb or bigger) and on larger numbers of seeds.

-Walt

Attachments (2)

PanicOnMini.rtf (7.1 KB) - added by zarkon55 11 years ago.
KP Dump
BuildLog_2010-08-05_10-09-23.txt.zip (8.9 KB) - added by zarkon55 11 years ago.
Build log showing lots of warnings including leaks…

Download all attachments as: .zip

Change History (12)

Changed 11 years ago by zarkon55

KP Dump

comment:1 follow-up: Changed 11 years ago by charles

What memory is being allocated and never referenced again?

comment:2 in reply to: ↑ 1 ; follow-up: Changed 11 years ago by zarkon55

Replying to charles:

What memory is being allocated and never referenced again?

I can send you a Xcode leaks trace file, but you should be able to do it yourself.. right?

My short trace is over 200Mb, so I'd need an FTP site to upload it, if you want it.

-Walt

comment:3 in reply to: ↑ 2 Changed 11 years ago by Rolcol

Replying to zarkon55:

Replying to charles:

What memory is being allocated and never referenced again?

I can send you a Xcode leaks trace file, but you should be able to do it yourself.. right?

Charles doesn't develop the Mac-specific part of Transmission. No access to Xcode.

My short trace is over 200Mb, so I'd need an FTP site to upload it, if you want it.

-Walt

200MB before or after compression? Filesharing site like Mediafire or Filevo would probably work. (I don't know. I'm not a dev.)

Changed 11 years ago by zarkon55

Build log showing lots of warnings including leaks...

comment:4 Changed 11 years ago by zarkon55

I attached a build log with "Analyze" turned on, to show some of the warnings...

When watching it run under Xcode, you can see the memory allocations grow..

It there a lead developer that handles the Mac-specific parts of Transmission?

I'm assuming no one else on other platforms are seeing the KPs...

-Walt

comment:5 Changed 11 years ago by zarkon55

BTW: version 2.03 is about 5x slower in overall completion speed than the older 1.8x, for any given torrent. What's up with that?

comment:6 Changed 11 years ago by Longinus00

Have you tried compiling with gcc?

comment:7 Changed 11 years ago by livings124

Are you sure that the increasing memory isn't just required memory allocation? Just because memory usage increases doesn't mean it's a leak. I do not see any valid leaks in that report: everything retained is released at some point.

Have you tried decreasing the number of running transfers, decreasing the number of allowed connections, and setting bandwidth limits?

comment:8 Changed 11 years ago by livings124

  • Keywords Kernal Panic KP removed
  • Summary changed from Kernal Panics to Kernel Panics

comment:9 Changed 11 years ago by zarkon55

My initial settings were for 152 connections, and only 2 active transfers. I've played around with higher and lower settings, but it does not seem to matter.

The Xcode leaks tool does not show the memory being released while running in real-time, but I have also not been able to get it to panic while running in debug mode under Xcode.

The only thing that for sure makes a difference, is that 1.8 does far fewer KPs than 2.03, and 1.8 runs about 5x faster than 2.03

We know for sure that this is software, because it happens on 2 different hardware platforms: The Mini and the MBP, with different chipsets, processors etc.

It could possibly be a Snow Leopard problem, but I don't want to revert any of my machines to a lower version to find out.

comment:10 Changed 11 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This ticket appears to be a duplicate of #3444.

Note: See TracTickets for help on using tickets.