Opened 12 years ago

Closed 12 years ago

#3490 closed Bug (fixed)

Ambiguous use of directory separators

Reported by: charles Owned by: charles
Priority: Normal Milestone: 2.10
Component: libtransmission Version: 2.03
Severity: Normal Keywords:
Cc:

Description

For a long time, libtransmission has used a TR_PATH_DELIMITER preprocessor macro inspired by glib. On Windows it resolves as "\"; elsewhere, it's "/"

The problem is in RPC client code that needs to parse the filenames returned by the server. Client code shouldn't need to know or care what OS the server is running on.

Since both Windows and Unix understand '/' as a path delimiter, we can fix this issue by using that unconditionally.

Change History (2)

comment:1 Changed 12 years ago by charles

  • Status changed from new to assigned

comment:2 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in trunk by r11126

Note: See TracTickets for help on using tickets.