Opened 12 years ago

Closed 12 years ago

#3501 closed Enhancement (wontfix)

Add modifier key support to filter buttons

Reported by: nickshanks Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 2.04
Severity: Normal Keywords:
Cc:

Description

I was trying to get a list of all downloading and paused torrents, and attempted to do the following:

  • Selected the Downloading filter, then Command-clicked the Paused filter button to add it to the selection. That didn't work, so I then tried,
  • Option-clicking the Seeding filter button, to select !seeding. That didn't work either.

I would expect the two operations to be identical except for the torrent that was currently being verified (if any), which would be listed in !seeding, but not listed in paused+downloading.

Change History (1)

comment:1 Changed 12 years ago by livings124

  • Resolution set to wontfix
  • Status changed from new to closed

The buttons are designed to behave like all other apps that use those buttons, so unfortunately those aren't supported by design. Also, that behavior seems unnecessarily complex and non-obvious.

Note: See TracTickets for help on using tickets.