Opened 11 years ago

Closed 11 years ago

#3503 closed Bug (duplicate)

qtr doesn't call mkdirp on remote session

Reported by: keizie Owned by: charles
Priority: Normal Milestone: None Set
Component: Qt Client Version: 2.04+
Severity: Normal Keywords:
Cc:

Description

Built on mac, qtr repeatedly show consent dialog. I wondered why and found that configDir not created. Consequently temporary settings.js failed to save on finalizing Prefs. Then next time it loads no settings.js and show first consent dialog. I created configDir myself and everything goes fine.

Other branches seems to call tr_sessionInit() so that number of mkdirp routines called there. But qt branch doesn't call tr_sessionInit() if SESSION_IS_REMOTE.

I don't know what is best practice of calling mkdirp somewhere in qt branch for remote session.

Change History (1)

comment:1 Changed 11 years ago by jordan

  • Resolution set to duplicate
  • Status changed from new to closed

Closing this ticket as a duplicate of #3938.

This ticket came first, so by rights #3938 should be closed as a duplicate of this one. However #3938 already has a lot writing in it, so I'm going to close this one instead... :/

Note: See TracTickets for help on using tickets.